HDU 2063 过山车 匈牙利算法模板题

过山车

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 15271    Accepted Submission(s): 6699


Problem Description
RPG girls今天和大家一起去游乐场玩,终于可以坐上梦寐以求的过山车了。可是,过山车的每一排只有两个座位,而且还有条不成文的规矩,就是每个女生必须找个个男生做partner和她同坐。但是,每个女孩都有各自的想法,举个例子把,Rabbit只愿意和XHD或PQK做partner,Grass只愿意和linle或LL做partner,PrincessSnow愿意和水域浪子或伪酷儿做partner。考虑到经费问题,boss刘决定只让找到partner的人去坐过山车,其他的人,嘿嘿,就站在下面看着吧。聪明的Acmer,你可以帮忙算算最多有多少对组合可以坐上过山车吗?
 

Input
输入数据的第一行是三个整数K , M , N,分别表示可能的组合数目,女生的人数,男生的人数。0<K<=1000
1<=N 和M<=500.接下来的K行,每行有两个数,分别表示女生Ai愿意和男生Bj做partner。最后一个0结束输入。
 

Output
对于每组数据,输出一个整数,表示可以坐上过山车的最多组合数。
 

Sample Input
  
  
6 3 3 1 1 1 2 1 3 2 1 2 3 3 1 0
 

Sample Output

3

//匈牙利算法模板题,不多说了
#include <iostream>
#include <cstdio>
#include <cstring>
#include <cctype>
#include <cmath>
#include <vector>
#include <algorithm>
using namespace std;

const int N = 1200;
vector <int> G[N];
int match[N];
bool use[N];
int n, m;

void add_edge(int a, int b)
{
    G[a].push_back(b);
    G[b].push_back(a);
}

bool dfs(int v)
{
    use[v] = true;
    for(int i = 0; i < G[v].size(); i++)
    {
        int u = G[v][i], w = match[u];
        if(w == -1 || (!use[w] && dfs(w)))
        {
            match[v] = u;
            match[u] = v;
            return true;
        }
    }

    return false;
}

int hungry()
{
    int res = 0;
    memset(match, -1, sizeof match);
    for(int i = 0; i <= n + m; i++)
        if(match[i] < 0)
        {
            memset(use, 0, sizeof use);
            if(dfs(i))
                res++;
        }
    return res;
}

int main()
{
    int t, a, b;

    while(scanf("%d", &t), t != 0)
    {
        scanf("%d%d", &n, &m);
        for(int i = 0; i < t; i++)
        {
            scanf("%d%d", &a, &b);
            add_edge(a, n + b);
        }

        printf("%d\n", hungry());
        for(int i = 0; i <= n + m; i++)
            G[i].clear();
    }

    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值