lightoj 1122 Digit Count

Description

Given a set of digits S, and an integer n, you have to find how many n-digit integers are there, which contain digits that belong to S and the difference between any two adjacent digits is not more than two.

Input

Input starts with an integer T (≤ 300), denoting the number of test cases.

Each case contains two integers, m (1 ≤ m < 10) and n (1 ≤ n ≤ 10). The next line will contain m integers (from 1 to 9) separated by spaces. These integers form the set S as described above. These integers will be distinct and given in ascending order.

Output

For each case, print the case number and the number of valid n-digit integers in a single line.

Sample Input

3

3 2

1 3 6

3 2

1 2 3

3 3

1 4 6

Sample Output

Case 1: 5

Case 2: 9

Case 3: 9

/*定义dp[i][j]为长为i位以第j个数结尾的满足题意的方案数*/
#include <iostream>
#include <cstdio>
#include <cmath>
#include <stack>
#include <vector>
#include <cstring>
#include <algorithm>
using namespace std;

const int N = 20;
int a[N];
int dp[N][N];

int main()
{
    int t, n, m, x = 0;
    scanf("%d", &t);
    while(t--)
    {
        scanf("%d%d", &n, &m);
        for(int i = 1; i <= n; i++)
            scanf("%d", a + i);

        memset(dp, 0, sizeof dp);
        for(int i = 1; i <= n; i++)
            dp[1][i] = 1;
        for(int i = 2; i <= m; i++)
            for(int j = 1; j <= n; j++)
                for(int k = 1; k <= n; k++)
                    if(abs(a[j] - a[k]) <= 2)
                        dp[i][j] += dp[i-1][k];
        int res = 0;
        for(int i = 1; i <= n; i++)
            res += dp[m][i];
        printf("Case %d: %d\n", ++x, res);
    }


    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值