题目:http://acm.hdu.edu.cn/showproblem.php?pid=2087
题意:
Problem Description
一块花布条,里面有些图案,另有一块直接可用的小饰条,里面也有一些图案。对于给定的花布条和小饰条,计算一下能从花布条中尽可能剪出几块小饰条来呢?
Input
输入中含有一些数据,分别是成对出现的花布条和小饰条,其布条都是用可见ASCII字符表示的,可见的ASCII字符有多少个,布条的花纹也有多少种花样。花纹条和小饰条不会超过1000个字符长。如果遇见#字符,则不再进行工作。
Output
输出能从花纹布中剪出的最多小饰条个数,如果一块都没有,那就老老实实输出0,每个结果之间应换行。
Sample Input
abcde a3 aaaaaa aa #
Sample Output
0 3
思路:用kmp算法去匹配,每匹配到一个,则在下一个位置用模式串从头开始匹配
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int N = 10010;
char s1[N], s2[N];
int nt[N];
void getnt()
{
int i = 0, j = -1;
nt[0] = -1;
while(s2[i])
{
if(j == -1 || s2[i] == s2[j])
{
i++, j++;
if(s2[i] != s2[j]) nt[i] = j;
else nt[i] = nt[j];
}
else j = nt[j];
}
}
int kmp()
{
getnt();
int i = 0, j = 0, cnt = 0;
while(s1[i])
{
if(j == -1 || s1[i] == s2[j])
i++, j++;
else j = nt[j];
if(j != -1 && ! s2[j])
cnt++, j = 0;//模式串从头开始匹配
}
return cnt;
}
int main()
{
while(scanf("%s", s1), s1[0] != '#')
{
scanf("%s", s2);
printf("%d\n", kmp());
}
return 0;
}