HDOJ-1028

Ignatius and the Princess III

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 24006 Accepted Submission(s): 16689

Problem Description

"Well, it seems the first problem is too easy. I will let you know how foolish you are later." feng5166 says.
"The second problem is, given an positive integer N, we define an equation like this:
N=a[1]+a[2]+a[3]+...+a[m];
a[i]>0,1<=m<=N;
My question is how many different equations you can find for a given N.
For example, assume N is 4, we can find:
4 = 4;
4 = 3 + 1;
4 = 2 + 2;
4 = 2 + 1 + 1;
4 = 1 + 1 + 1 + 1;
so the result is 5 when N is 4. Note that "4 = 3 + 1" and "4 = 1 + 3" is the same in this problem. Now, you do it!"

Input

The input contains several test cases. Each test case contains a positive
integer N(1<=N<=120) which is mentioned above. The input is
terminated by the end of file.

Output

For each test case, you have to output a line contains an integer P which indicate the different equations you have found.

Sample Input
4
10
20
Sample Output
5
42
627

其实就是一道组合数学题,考察的知识点是母函数:

母函数相关知识:

定义

对于序列a0,a1,a2,…构造函数G(x):
这里写图片描述
则称函数G(x)是序列a0,a1,a2,…的母函数。 在组合数学中,母函数起到将加法法则与乘法法则结合起来的作用。详细见举例:

Example

砝码问题

经典的母函数问题就是砝码问题,即若有1克、2克、3克、4克的砝码各一枚,能称出哪几种重量?各有几种可能方案?

利用母函数,可以轻松求解该问题。

考虑构造母函数,用x的指数表示称出的质量,则:

1个1克的砝码可以用函数1+x表示,

1个2克的砝码可以用函数1+\(x^2\)表示,

1个3克的砝码可以用函数1+\(x^3\)表示,

1个4克的砝码可以用函数1+\(x^4\)表示,

几种砝码的组合可以称重的情况,可以用以上几个函数的乘积表示:

(1+\(x\))( 1+\(x^2\))( 1+\(x^3\))( 1+\(x^4\)),将该式子展开,x的指数表示可以称出的重量,其系数表示该种重量的方案数。

这道问题同理,构造函数

\(G(x)\) = \((1+x+x^2+...+x^n)(1+x^2+x^4+...)...(1+x^n)\)

拆开计算\(G(x)\)前系数即可。

关于母函数的更多资料:

1、https://en.wikipedia.org/wiki/Generating_function

2、https://baike.baidu.com/item/%E6%AF%8D%E5%87%BD%E6%95%B0/4836270?fr=aladdin


#include <stdio.h>
#include <stdlib.h>
using namespace std;
#define MAX_SIZE 128
int tmp[MAX_SIZE];
int res[MAX_SIZE];
int solution(int n)
{
    int i, j, k;
    for (i = 2; i <= n; i++)
    {
        for (j = 0; j <= n; j++)
        {
            for (int k = 0; k + j <= n; k += i)
            {
                tmp[j + k] += res[j];
            }
        }

        for (int i = 0; i <= n; i++)
        {
            res[i] = tmp[i];
            tmp[i] = 0;
        }
    }

    return res[n];
}
int main()
{
    int n;

    while (scanf("%d", &n) != EOF)
    {
        for (int i = 0; i < MAX_SIZE; i++)
        {
            res[i] = 1;
            tmp[i] = 0;
        }

        int ret = solution(n);

        printf("%d\n", ret);
    }
}

转载于:https://www.cnblogs.com/KarlZhang/p/8644937.html

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值