UVALive 6862 Triples (找规律 暴力)

Triples

题目链接:

http://acm.hust.edu.cn/vjudge/contest/130303#problem/H

Description


http://7xjob4.com1.z0.glb.clouddn.com/4c05ed01e62e808388fc90e37554d588

Input


The input file contains several test cases, each of them as described below.
The first line contains the value of m and the second line contains the value of n.

Output


For each test case, the result will be written to standard output, on a line by itself.

Sample Input

85
95

Sample Output

8128

Source


2016-HUST-线下组队赛-4


题意:


求有多少个三元组(x,y,z)满足 0<=x<=y<=z<=m 且 x^j + y^j = z^j.


题解:


由于n和m的数据都非常小,稍微打一下表就可以发现 j > 2 的时候不存在满足条件的三元组.
upd:实际上,上述表述为费马大定理
x=0时:y = z ∈ [0, m]. 故有 (m+1) * (n-1) 个解.
j=2时:暴力求一下即可.


代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <string>
#include <algorithm>
#include <vector>
#include <map>
#include <set>
#include <queue>
#include <stack>
#define LL long long
#define maxn 101000
#define inf 0x3f3f3f3f
#define mod 1000000007
#define mid(a,b) ((a+b)>>1)
#define eps 1e-8
#define IN freopen("in.txt","r",stdin);
using namespace std;

int solve(int m) {
    int cnt = 0;
    for(LL i=1; i<=m; i++) {
        for(LL j=i; j<=m; j++) {
            LL x = i*i + j*j;
            for(LL k=0; k<=m; k++) {
                if(k*k == x) {
                    //printf("%d %d %d\n",i,j,k);
                    cnt++;
                    break;
                }
            }
        }
    }
    return cnt;
}

int main()
{
    //IN;

    int m,n;
    while(scanf("%d %d", &m,&n) != EOF)
    {
        int ans = solve(m) + (m+1)*(n-1);

        printf("%d\n", ans);
    }

    return 0;
}

转载于:https://www.cnblogs.com/Sunshine-tcf/p/5811116.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值