Zoj1628--Diamond(Dfs《暴力》)

Diamond

Time Limit: 2 Seconds      Memory Limit: 65536 KB

Diamond mine is a mini-game which is played on an 8 * 8 board as you can see below.

The board is filled with different colors of diamonds. The player can make one move at a time. A move is legal if it swaps two adjacent diamonds(not diagonally) and after that, there are three or more adjacent diamonds in a row or column with the same color. Those diamonds will be taken away and new diamonds will be put in their positions. The game continues until no legal moves exist.


Given the board description. You are going to determine whether a move is legal.


Input

The input contains several cases. Each case has exactly 9 lines. The first 8 lines each contains a string of 8 characters. The characters are 'R'(Red), 'O'(Orange), 'G'(Green), 'P'(Purple), 'W'(White), 'Y'(Yellow) or 'B'(Blue). All characters are uppercase. No 3 diamonds of the same color are initially in adjacent positions in a row or column. The last line has 4 integers in the form " row1 column1 row2 column2" describing the postions of the 2 diamonds that the player wants to swap. Rows are marked 1 to 8 increasingly from top to bottom while columns from left to right. Input is terminated by EOF.


Output

For each case, output "Ok!" if the move is legal or "Illegal move!" if it is not.


Sample Input

PBPOWBGW
RRPRYWWP
YGBYYGPP
OWYGGRWB
GBBGBGGR
GBWPPORG
PPGORWOG
WYWGYWBY
4 3 3 3
PBPOWBGW
RRPRYWWP
YGBYYGPP
OWYGGRWB
GBBGBGGR
GBWPPORG
PPGORWOG
WYWGYWBY
5 5 6 5


Sample Output

Ok!
Illegal move!

 


Author: PAN, Minghao
Source: ZOJ Monthly, June 2003

话说一不小心WA了一晚上, 我nm。

ac码:

#include <cmath> 
#include <cstdio>
#include <iostream>
using namespace std;
char map[10][10];
bool Dfs(int a, int b)    //相当于往四个方向搜。
{
    int flag1 = 0, flag2 = 0; 
    for(int i = a; i >= 1; i--)
    {
        if(map[i][b] == map[a][b])
            flag1++;
        else
            break;
    }
    for(int i = a+1; i <= 8; i++)
    {
        if(map[i][b] == map[a][b])
            flag1++;
        else
            break; 
    }
    if(flag1 >= 3)
        return true;
    for(int i = b; i >= 1; i--)
    {
        if(map[a][i]==map[a][b])
            flag2++;
        else
             break;
    }
    for(int i = b + 1; i <= 8; i++)
    {
        if(map[a][i]== map[a][b])
            flag2++;
        else
            break;    
    } 
    if(flag2 >= 3)
        return true;
    return false;
}
int main()
{
    while(cin >> map[1][1])
    {
        for(int i = 1; i <= 8; i++)
            for(int j = 1; j <= 8; j++)
            {
                if(i == 1 && j == 1)
                    continue; 
                else
                    cin >> map[i][j];
            }
        int a, b, c, d;
        scanf("%d %d %d %d", &a, &b, &c, &d); 
        if(abs(a-c) + abs(b-d) != 1){                           //xiaojianzhi
            printf("Illegal move!\n");
            continue; 
        }
        char s;
        s = map[a][b];map[a][b] = map[c][d]; map[c][d] = s;   //  swap position.
        if(Dfs(a, b) || Dfs(c, d))
            printf("Ok!\n");
        else
            printf("Illegal move!\n");
    }
    return 0;    
} 

 

转载于:https://www.cnblogs.com/soTired/p/4759033.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值