Zoj3944 - People Counting

在浙江大学ICPC团队的一次聚餐中,教练们希望通过一张照片来统计到场人数。经过预处理,照片被转换为一个字符矩阵,需要用特定的符号模式来识别每个人。此文章介绍了一种算法,通过解析这个矩阵并查找指定的符号组合来计算照片中的人物数量。
摘要由CSDN通过智能技术生成
People Counting

Time Limit: 2 Seconds      Memory Limit: 65536 KB

In a BG (dinner gathering) for ZJU ICPC team, the coaches wanted to count the number of people present at the BG. They did that by having the waitress take a photo for them. Everyone was in the photo and no one was completely blocked. Each person in the photo has the same posture. After some preprocessing, the photo was converted into a H×W character matrix, with the background represented by ".". Thus a person in this photo is represented by the diagram in the following three lines:

.O.
/|\
(.)

Given the character matrix, the coaches want you to count the number of people in the photo. Note that if someone is partly blocked in the photo, only part of the above diagram will be presented in the character matrix.

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

The first contains two integers H, W (1 ≤ H, W ≤ 100) - as described above, followed by H lines, showing the matrix representation of the photo.

Output

For each test case, there should be a single line, containing an integer indicating the number of people from the photo.

Sample Input
2
3 3
.O.
/|\
(.)
3 4
OOO(
/|\\
()))
Sample Output
1
4

Author: Lu, Yi
Source: The 13th Zhejiang Provincial Collegiate Programming Contest

统计小人个数;  泪流满面!!

#include <cstdio>
#include <cstring>
#define N 110
char G[N][N]; int v[N][N];
int n , m;
using namespace std ;
void check()
{
        for(int i=0; i< n; i++)
                for( int j=0; j<m; j++)
                {
                    printf("%c", G[i][j]);
                    if(j== m-1) printf("\n");
                }
}
bool judge(int a, int b)
{
    if(a>= 0&& a< n && b>= 0 && b < m) 
        return true;
    else 
        return false;
}
int main()
{
    int t; scanf("%d", &t);
    while(t--)
    {
        scanf("%d%d", &n, &m);    
        for(int i=0; i <n; i++)
        {
            scanf ("%s", G[i]);
        }
        int sum= 0;
        for(int i=0; i< n; i++)
            for(int j=0; j< m; j++)
            {
                
                if(G[i][j]=='.') continue;
                if(G[i][j]=='O')
                {
                    sum += 1;
                    G[i][j]= '.';
                    if(judge( i+1, j) && G[i+1][j]=='|') G[i+1][j]='.';
                    if(judge( i+1, j-1) &&G[i+1][j-1]=='/') G[i+1][j-1]= '.';
                    if(judge( i+1, j+1) &&G[i+1][j+1]=='\\') G[i+1][j+1]= '.';
                    if(judge( i+2, j-1) &&G[i+2][j-1]== '(') G[i+2][j-1]= '.';
                    if(judge( i+2, j+1) &&G[i+2][j+1]== ')') G[i+2][j+1]= '.';
                }
                
                if(G[i][j]== '/')
                {
                    sum += 1;
                    G[i][j]= '.';
                    if(judge( i, j+1) &&G[i][j+1]== '|') G[i][j+1]= '.';
                    if(judge( i, j+2) &&G[i][j+2]== '\\') G[i][j+2]= '.';
                    if(judge( i+1, j) &&G[i+1][j]=='(') G[i+1][j]= '.';
                    if(judge( i+1, j+2) &&G[i+1][j+2]== ')') G[i+1][j+2]= '.';
                }
                
                if(G[i][j]== '|')
                {
                    sum += 1;
                    G[i][j]= '.';
                    if(judge( i, j+1) &&G[i][j+1]== '\\') G[i][j+1] ='.';
                    if(judge( i+1, j-1) &&G[i+1][j-1]== '(') G[i+1][j-1]= '.';
                    if(judge( i+1, j+1) &&G[i+1][j+1]== ')') G[i+1][j+1]= '.';
                }
                
                if(G[i][j]=='\\')
                {
                    sum += 1;
                    G[i][j]= '.';
                    if(judge( i+1, j) &&G[i+1][j]== ')') G[i+1][j]= '.';
                    if(judge( i+1, j-2) &&G[i+1][j-2]=='(') G[i+1][j-2]= '.'; 
                }
                if(G[i][j]== '(')
                {
                    sum += 1;
                    G[i][j]= '.';
                    if(judge( i,j+2) &&G[i][j+2]== ')') G[i][j+2]= '.';  
                }
                if(G[i][j]== ')')
                {
                    sum += 1;
                    G[i][j]='.';
                }
            }
        printf("%d\n", sum);
    }
    
    return 0;
}

 

转载于:https://www.cnblogs.com/soTired/p/5426728.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值