zoj 3944

Time Limit:2000MS     Memory Limit:65536KB     64bit IO Format:%lld & %llu

Description

In a BG (dinner gathering) for ZJU ICPC team, the coaches wanted to count the number of people present at the BG. They did that by having the waitress take a photo for them. Everyone was in the photo and no one was completely blocked. Each person in the photo has the same posture. After some preprocessing, the photo was converted into a H×W character matrix, with the background represented by ".". Thus a person in this photo is represented by the diagram in the following three lines:

.O.
/|\
(.)

Given the character matrix, the coaches want you to count the number of people in the photo. Note that if someone is partly blocked in the photo, only part of the above diagram will be presented in the character matrix.

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

The first contains two integers HW (1 ≤ HW ≤ 100) - as described above, followed by H lines, showing the matrix representation of the photo.

Output

For each test case, there should be a single line, containing an integer indicating the number of people from the photo.

Sample Input

2
3 3
.O.
/|\
(.)
3 4
OOO(
/|\\
()))

Sample Output

1
4
 
     
深搜思维,把一个器官周围的器官全部消去,类似于深搜的八连通问题,然而比赛时并没有联想到这一层

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
char str[200][200];
void dfs1(int x, int y);
void dfs2(int x, int y);
void dfs3(int x, int y);
void dfs4(int x, int y);
void dfs5(int x, int y);
void dfs6(int x, int y);
int n, m;


int main()
{
    int t;
    cin>>t;
    while(t--)
    {
        memset(str,0,sizeof(str));
        cin>>n>>m;
        for(int i=0;i<n;i++)
        {
            scanf(" %s",str[i]);
        }
        int cnt=0;
        for(int i=0;i<n;i++)
        {
            for(int j=0;j<m;j++)
            {
                if(str[i][j]=='O')
                {
                    cnt++;
                    dfs1(i,j);
                }
                else if(str[i][j]=='|')
                {
                    cnt++;
                    dfs2(i,j);
                }
                else if(str[i][j]=='/')
                {
                    cnt++;
                    dfs3(i,j);
                }
                else if(str[i][j]=='\\')
                {
                    cnt++;
                    dfs4(i,j);
                }
                else if(str[i][j]=='(')
                {
                    cnt++;
                    dfs5(i,j);
                }
                else if(str[i][j]==')')
                {
                    cnt++;
                    dfs6(i,j);
                }
            }
        }
        cout<<cnt<<endl;
    }
    return 0;
}


void dfs1(int x, int y)
{
    str[x][y]='.';
    if(x+1<n&&str[x+1][y]=='|')
    {
        str[x+1][y]='.';
    }
    if(x+1<n&&y-1>=0&&str[x+1][y-1]=='/')
    {
        str[x+1][y-1]='.';
    }
    if(x+1<n&&y+1<m&&str[x+1][y+1]=='\\')
    {
        str[x+1][y+1]='.';
    }
    if(x+2<n&&y-1>=0&&str[x+2][y-1]=='(')
    {
        str[x+2][y-1]='.';
    }
    if(x+2<n&&y+1<m&&str[x+2][y+1]==')')
    {
        str[x+2][y+1]='.';
    }
    return ;
}




void dfs2(int x, int y)
{
    str[x][y]='.';
    if(y+1<m&&str[x][y+1]=='\\')
    {
        str[x][y+1]='.';
    }
    if(x+1<n&&y-1>=0&&str[x+1][y-1]=='(')
    {
        str[x+1][y-1]='.';
    }
    if(x+1<n&&y+1<m&&str[x+1][y+1]==')')
    {
        str[x+1][y+1]='.';
    }
    return ;
}




void dfs3(int x, int y)
{
    str[x][y]='.';
    if(y+1<m&&str[x][y+1]=='|')
    {
        str[x][y+1]='.';
    }
    if(y+2<m&&str[x][y+2]=='\\')
    {
        str[x][y+2]='.';
    }
    if(x+1<n&&str[x+1][y]=='(')
    {
        str[x+1][y]='.';
    }
    if(x+1<n&&y+2<m&&str[x+1][y+2]==')')
    {
        str[x+1][y+2]='.';
    }
    return ;
}


void dfs4(int x, int y)
{
    str[x][y]='.';
    if(x+1<n&&y-2>=0&&str[x+1][y-2]=='(')
    {
        str[x+1][y-2]='.';
    }
    if(x+1<n&&str[x+1][y]==')')
    {
        str[x+1][y]='.';
    }
    return ;
}




void dfs5(int x, int y)
{
    str[x][y]='.';
    if(y+2<m&&str[x][y+2]==')')
    {
        str[x][y+2]='.';
    }
    return ;
}


void dfs6(int x, int y)
{
    str[x][y]='.';
    return ;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值