求三角形面积

给定三角形三个顶点的坐标,计算三角形的面积。
Input
有多组数据。每组数据由6个双精度数组成,分别表示三角形三个顶点的坐标。

Output
三角形的面积。如果三点在一条直线上,则输出“not a triangle”。
Sample Input
10 20 30 40 50 60
3874 487 34587 45687 234 45
Sample Output
not a triangle!
area=75476427.00
在这里插入图片描述

#include<stdio.h>
#include<math.h>
int main(){
double x1,y1,x2,y2,x3,y3,a,b,c,p,s;
while(~scanf("%lf %lf %lf %lf %lf %lf",&x1,&y1,&x2,&y2,&x3,&y3)){
     a=sqrt((x1-x2)*(x1-x2)+(y1-y2)*(y1-y2));
    b=sqrt((x1-x3)*(x1-x3)+(y1-y3)*(y1-y3));
    c=sqrt((x3-x2)*(x3-x2)+(y3-y2)*(y3-y2));
    p=(a+b+c)/2;
    s=sqrt(p*(p-a)*(p-b)*(p-c));
    if(s==0){
        printf("not a triangle!\n");
    }
    else printf("area=%.2lf\n",s);
}
return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值