POJ 3636 Nested Dolls

Nested Dolls

Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Description

Dilworth is the world’s most prominent collector of Russian nested dolls: he literally has thousands of them! You know, the wooden hollow dolls of different sizes of which the smallest doll is contained in the second smallest, and this doll is in turn contained in the next one and so forth. One day he wonders if there is another way of nesting them so he will end up with fewer nested dolls? After all, that would make his collection even more magnificent! He unpacks each nested doll and measures the width and height of each contained doll. A doll with width w1 and height h1 will fit in another doll of width w2 and height h2 if and only if w1 < w2 and h1 < h2. Can you help him calculate the smallest number of nested dolls possible to assemble from his massive list of measurements? 
 

Input

On the first line of input is a single positive integer 1 <= t <= 20 specifying the number of test cases to follow. Each test case begins with a positive integer 1 <= m <= 20000 on a line of itself telling the number of dolls in the test case. Next follow 2m positive integers w1, h1,w2, h2, . . . ,wm, hm, where wi is the width and hi is the height of doll number i. 1 <= wi, hi <= 10000 for all i. 
 

Output

For each test case there should be one line of output containing the minimum number of nested dolls possible. 
 

Sample Input

    
    
4
3
20 30 40 50 30 40
4
20 30 10 10 30 20 40 50
3
10 30 20 20 30 10
4
10 10 20 30 40 50 39 51
 

Sample Output

    
    
1 2 3 2

题意:题的大意是给你空心娃娃的宽w和高h,当wi > wj 且 hi > hj时,空心娃娃j可以嵌套进娃娃i中,问所有满足嵌套条件的娃娃嵌套在一起后,露在外面的娃娃最多有多少

分析:这道题跟NYOJ上的矩形嵌套类似,都是单调递增子序列的变形。不过这道题的数据范围太大,一开始用普通求单调递增子序列的方法超时了,然后又用upper_bound和lower_bound这两个STL函数写,终于AC了。。。

#include <stdio.h>
#include <string.h>
#include <iostream>
#include <algorithm>

using namespace std;

const int INF = 0x3f3f3f3f;
int dp[20010];

struct pp
{
    int w,h;
} a[20010];
//先按宽度由大到小排序,如果宽度相等,高由小到大
bool cmp(pp a,pp b)
{
    if(a.w == b.w)
        return a.h < b.h;
    return a.w > b.w;
}

int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int n;
        scanf("%d",&n);
        for(int i = 0; i < n; i++)
        {
            scanf("%d %d",&a[i].w,&a[i].h);
        }
        sort(a,a + n,cmp);
        memset(dp,INF,sizeof(dp));
        int ans = 0;
        for(int i = 0; i < n; i++)
        {
            *upper_bound(dp,dp + n,a[i].h) = a[i].h;//不是lower_bound的原因是不能够相等
        }
        printf("%d\n", lower_bound(dp,dp + n,INF) - dp);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值