题目描述:
输入年月日,计算该天是本年的第几天。
输入:
包括3个整数:年,月,日
输出:
输入可能有多组测试数据,对于每组测试数据,输出一个整数,代表Input中的年月日对应本年的第几天。
样例输入:
1990 9 20
2000 5 1
样例输出:
263
122
代码:
#include <iostream>
#include <cstdio>
using namespace std;
int daytab[2][13] = {
{0, 31, 28, 31, 30, 31, 30, 31, 31, 30, 31, 30, 31},
{0, 31, 29, 31, 30, 31, 30, 31, 31, 30, 31, 30, 31}
};
bool isleapyear(int year) {
return (year % 4 == 0 && year % 100 != 0) || (year % 400 == 0);
}
int main() {
int year, month, day;
while (scanf("%d%d%d", &year, &month, &day) != EOF) {
int number = 0;
int row = isleapyear(year);
for (int j = 0; j < month; j++) {
number += daytab[row][j];
}
number += day;
printf("%d\n", number);
}
return 0;
}