Gray code
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)Total Submission(s): 983 Accepted Submission(s): 548
Problem Description
The reflected binary code, also known as Gray code after Frank Gray, is a binary numeral system where two successive values differ in only onebit (binary digit). The reflected binary code was originally designed to prevent spurious output from electromechanical switches. Today, Gray codes are widely used to facilitate error correction in digital communications such as digital terrestrial television and some cable TV systems.
Now , you are given a binary number of length n including ‘0’ , ’1’ and ‘?’(? means that you can use either 0 or 1 to fill this position) and n integers(a1,a2,….,an) . A certain binary number corresponds to a gray code only. If the ith bit of this gray code is 1,you can get the point ai.
Can you tell me how many points you can get at most?
For instance, the binary number “00?0” may be “0000” or “0010”,and the corresponding gray code are “0000” or “0011”.You can choose “0000” getting nothing or “0011” getting the point a3 and a4.
Now , you are given a binary number of length n including ‘0’ , ’1’ and ‘?’(? means that you can use either 0 or 1 to fill this position) and n integers(a1,a2,….,an) . A certain binary number corresponds to a gray code only. If the ith bit of this gray code is 1,you can get the point ai.
Can you tell me how many points you can get at most?
For instance, the binary number “00?0” may be “0000” or “0010”,and the corresponding gray code are “0000” or “0011”.You can choose “0000” getting nothing or “0011” getting the point a3 and a4.
Input
The first line of the input contains the number of test cases T.
Each test case begins with string with ‘0’,’1’ and ‘?’.
The next line contains n (1<=n<=200000) integers (n is the length of the string).
a1 a2 a3 … an (1<=ai<=1000)
Each test case begins with string with ‘0’,’1’ and ‘?’.
The next line contains n (1<=n<=200000) integers (n is the length of the string).
a1 a2 a3 … an (1<=ai<=1000)
Output
For each test case, output “Case #x: ans”, in which x is the case number counted from one,’ans’ is the points you can get at most
Sample Input
2 00?0 1 2 4 8 ???? 1 2 4 8
Sample Output
Case #1: 12 Case #2: 15Hinthttps://en.wikipedia.org/wiki/Gray_code http://baike.baidu.com/view/358724.htm
题意:就是格雷尔码,不知道的可以百度一下格雷尔码的转化规则。以dp[i][0~1]表示第i个字符尾0或1的获得最大值,如果是0或1则固定,是’?‘则转移。
#include<iostream>
#include<algorithm>
#include<cstring>
#include<cstdio>
#include<queue>
#include<vector>
#include<map>
#include<cmath>
#include<fstream>
#include<stack>
using namespace std;
typedef long long ll;
char s[200020];
int dp[200020][2], v[200020];
int inf = 0x3f3f3f3f;
int main()
{
int t;
cin>>t;
for(int cas = 1; cas<=t; cas++)
{
scanf("%s", s+1);
int len = strlen(s+1);
for(int i = 1; i<=len; i++)
scanf("%d", &v[i]);
memset(dp, 0, sizeof(dp));
if(s[1] == '0')
{
dp[1][0] = 0;
dp[1][1] = -inf;
}
else if(s[1] == '1')
{
dp[1][1] = v[1];
dp[1][0] = -inf;
}
else
{
dp[1][0] = 0;
dp[1][1] = v[1];
}
for(int i = 2; i<=len; i++)
{
if(s[i] == '0')
{
dp[i][1] = -inf;;
dp[i][0] = max(dp[i-1][1] + v[i], dp[i-1][0]);
}
if(s[i] == '1')
{
dp[i][0] = -inf;
dp[i][1] = max(dp[i-1][0] + v[i], dp[i-1][1]);
}
if(s[i] == '?')
{
dp[i][1] = max(dp[i-1][0] + v[i], dp[i-1][1]);
dp[i][0] = max(dp[i-1][1] + v[i], dp[i-1][0]);
}
}
printf("Case #%d: %d\n", cas, max(dp[len][0], dp[len][1]));
}
return 0;
}