poj-1258-Agri-Net

 

Farmer John has been elected mayor of his town! One of his campaign promises was to bring internet connectivity to all farms in the area. He needs your help, of course.
Farmer John ordered a high speed connection for his farm and is going to share his connectivity with the other farmers. To minimize cost, he wants to lay the minimum amount of optical fiber to connect his farm to all the other farms. 
Given a list of how much fiber it takes to connect each pair of farms, you must find the minimum amount of fiber needed to connect them all together. Each farm must connect to some other farm such that a packet can flow from any one farm to any other farm. 
The distance between any two farms will not exceed 100,000. 

Input

The input includes several cases. For each case, the first line contains the number of farms, N (3 <= N <= 100). The following lines contain the N x N conectivity matrix, where each element shows the distance from on farm to another. Logically, they are N lines of N space-separated integers. Physically, they are limited in length to 80 characters, so some lines continue onto others. Of course, the diagonal will be 0, since the distance from farm i to itself is not interesting for this problem.

Output

For each case, output a single integer length that is the sum of the minimum length of fiber required to connect the entire set of farms.

Sample Input

4
0 4 9 21
4 0 8 17
9 8 0 16
21 17 16 0

Sample Output

28

 

 

题意:说白了就是求最小生成树。

中考考砸了好不爽_(:з」∠)_

 

看到数据范围和输入格式,我就想,干脆用prim吧,不想转成边然后排序,反正也不会TLE——能AC就行。

(虽然我一个多月没写过这些了可能这次写丑了)

 

/何谓prim//

就是最开始选一个点到最小生成树中,然后每次添加一个离树的距离最短的点。

简介完毕///

 

还有一个事情,这道题有多组数据!多组数据!多组数据!!该清零的清零!(可是我并不是WA在这里呢)

我之前压根没发现这道题有多组数据..........

 

 

 

下为代码。

 

#include<cstdio>
#include<cstring>
int a[105][105],n,itr[105],ans;
bool ir[105];
int main()
{
	int i,j,k,minn,c;
	while(scanf("%d",&n)==1)
	{
		memset(ir,0,sizeof(ir));
		ir[1]=true;ans=0;itr[1]=1;
		for(i=1;i<=n;i++)
			for(j=1;j<=n;j++)
				scanf("%d",&a[i][j]);
		for(i=2;i<=n;i++)
		{
			minn=100001;
			for(j=1;j<i;j++)
				for(k=1;k<=n;k++)
					if(!ir[k]&&minn>a[itr[j]][k])
					{
						minn=a[itr[j]][k];c=k;
					}
			itr[i]=c;ir[c]=1;ans+=minn;
		}
		printf("%d\n",ans);
	}
}

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值