HDU 1042

N!

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 49365    Accepted Submission(s): 13859


Problem Description
Given an integer N(0 ≤ N ≤ 10000), your task is to calculate N!
 

Input
One N in one line, process to the end of file.
 

Output
For each N, output N! in one line.
 

Sample Input
  
  
1 2 3
 

Sample Output
  
  
1 2 6
 

Author
JGShining(极光炫影)
 

Recommend
We have carefully selected several similar problems for you:   1715  1047  1063  1753  1316 
 

Statistic |  Submit |  Discuss |  Note

思路:这里涉及到大数操作,下面分析一下大数阶乘的原理:

如果结果只有一位数,我们就存放在str[0]中。

如果结果有两位以上,就牵涉到进位操作。

str[0]存放结果的个位数,str[1]存放十位数,str[2]存放百位数,str[3]存放千位数。

具体存放状态如下:(结果倒数输出)


/*
	Title:HDU 1042
	Author:Dojking 
*/
#include <iostream>
#include <string>
using namespace std;

int main()
{
	int i, j, n, up, next;
	
	while (scanf("%d", &n) != EOF)
	{
		string str;
		str += '1';     //将 str[0] 初始化为1 
		up = 0;         //up 表示进位 
		next = 0;       //next 表示乘以下一个数后的总结果 
		for (i = 2; i <= n; ++i)
		{
			up = 0;
			for (j = 0; j < str.length(); ++j)
			{
				next = (str[j]-'0') * i + up;   
				if (next > 9 && str[j+1] == '\0')  //最后一位需要进位,则在末尾追加一个值为0的空间 
					str += '0';
				str[j] = next % 10 + '0';          //当前位 
				up = next / 10;                    //进位 
			}
		}
		for (i = str.length()-1; i >= 0; --i)      //逆序输出 
			cout<<str[i];
		cout<<endl;
	}
	return 0;
}

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值