Squares

Squares

Time Limit : 7000/3500ms (Java/Other)   Memory Limit : 131072/65536K (Java/Other)
Total Submission(s) : 4   Accepted Submission(s) : 4
Problem Description
A square is a 4-sided polygon whose sides have equal length and adjacent sides form 90-degree angles. It is also a polygon such that rotating about its centre by 90 degrees gives the same polygon. It is not the only polygon with the latter property, however, as a regular octagon also has this property. 

So we all know what a square looks like, but can we find all possible squares that can be formed from a set of stars in a night sky? To make the problem easier, we will assume that the night sky is a 2-dimensional plane, and each star is specified by its x and y coordinates. 
 

Input
The input consists of a number of test cases. Each test case starts with the integer n (1 <= n <= 1000) indicating the number of points to follow. Each of the next n lines specify the x and y coordinates (two integers) of each point. You may assume that the points are distinct and the magnitudes of the coordinates are less than 20000. The input is terminated when n = 0.
 

Output
For each test case, print on a line the number of squares one can form from the given stars.
 

Sample Input
  
  
4 1 0 0 1 1 1 0 0 9 0 0 1 0 2 0 0 2 1 2 2 2 0 1 1 1 2 1 4 -2 5 3 7 0 0 5 2 0
 

Sample Output
  
  
1 6 1
 

Source
PKU
 
#include <map>
#include <set>
#include <list>
#include <queue>
#include <stack>
#include <cmath>
#include <ctime>
#include <vector>
#include <bitset>
#include <cstdio>
#include <string>
#include <numeric>
#include <cstring>
#include <cstdlib>
#include <iostream>
#include <algorithm>
#include <functional>
using namespace std;
typedef long long  ll;
typedef unsigned long long ull;

int dx[4]= {-1,1,0,0};
int dy[4]= {0,0,-1,1}; //up down left right
bool inmap(int x,int y,int n,int m)
{
    if(x<1||x>n||y<1||y>m)return false;
    return true;
}
int hashmap(int x,int y,int m)
{
    return (x-1)*m+y;
}

#define eps 1e-8
#define inf 0x7fffffff
#define debug puts("BUG")
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
#define read freopen("in.txt","r",stdin)
#define write freopen("out.txt","w",stdout)
#define maxn 1111

int n;
struct Node
{
    int x,y;
} a[maxn];

bool operator <(const Node a,const Node b)
{
    if(a.x==b.x)
        return a.y<b.y;
    else
        return a.x<b.x;
}

int main()
{
    while(~scanf("%d",&n)&&n)
    {
        memset(a,0,sizeof(a));

        for(int i=0; i<n; i++)
            scanf("%d%d",&a[i].x,&a[i].y);
        sort(a,a+n);

/**
    *template <class ForwardIterator, class LessThanComparable>
    **bool binary_search(ForwardIterator first, ForwardIterator last,const LessThanComparable& value);

    *template <class ForwardIterator, class T, class StrictWeakOrdering>
    **bool binary_search(ForwardIterator first, ForwardIterator last, const T& value,StrictWeakOrdering comp);
**/
        int ans=0;
        for(int j=0;j<n;j++)//枚举两个点,再计算出剩下两个点,从原来的集合中进行查找~~用二分查找~~
            for(int k=j+1;k<n;k++)/**binary_search()**/
        {
            Node t;
            t.x=a[j].x+a[j].y-a[k].y;//第三个点横坐标:x1+y1-y2
            t.y=a[j].y-a[j].x+a[k].x;//        纵坐标:y1-x1+x2
            if(!binary_search(a,a+n,t))
                continue;
            t.x =a[k].x+a[j].y-a[k].y;//第四个点横坐标:x2+y1-y2
            t.y =a[k].y-a[j].x+a[k].x;//        纵坐标:y2-x1+x2
            if(!binary_search(a,a+n,t))
                continue;
            ans++;
        }
        printf("%d\n",ans/2);
    }
    return 0;
}
/**
   Hash(转)
**/
#include<iostream>
#include<cmath>
#include<algorithm>
using namespace std;
const int nMax = 1005;
const int mMax = 40005;

struct data
{
    int x, y;
} node[nMax], tmp;
int next[nMax], hash[mMax];    //  学习hash这种存储下标的方法,而不用存详细信息。

bool cmp(const data &a, const data &b)
{
    if(a.x == b.x) return a.y < b.y;
    return a.x < b.x;
}

bool search()                  //  寻找是否有点tmp。
{
    int key = abs(tmp.x + tmp.y);
    int i = hash[key];
    while(i != -1)
    {
        if(node[i].x == tmp.x && node[i].y == tmp.y)
            return true;
        i = next[i];
    }
    return false;
}

int main()
{
    int n, i, j;
    while(scanf("%d", &n) && n)
    {
        memset(hash, -1, sizeof(hash));
        for(i = 0; i < n; i ++)
            scanf("%d%d", &node[i].x, &node[i].y);
        sort(node, node + n, cmp);
        for(i = 0; i < n; i ++)
        {
            int key = abs(node[i].x + node[i].y);
            next[i] = hash[key];
            hash[key] = i;
        }
        int ans = 0;
        for(i = 0; i < n; i ++)
            for(j = i + 1; j < n; j ++)
            {
                tmp.x = node[i].x + node[i].y - node[j].y;
                tmp.y = node[i].y - node[i].x + node[j].x;
                if(!search()) continue;
                tmp.x = node[j].x + node[i].y - node[j].y;
                tmp.y = node[j].y - node[i].x + node[j].x;
                if(!search()) continue;
                ans ++;
            }
        printf("%d\n", ans/2);
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值