动态规划之完全背包搭配题目HDU1114:Piggy-Bank

HDU1114: Piggy-Bank

Problem Description
Before ACM can do anything, a budget must be prepared and the necessary financial support obtained. The main income for this action comes from Irreversibly Bound Money (IBM). The idea behind is simple. Whenever some ACM member has any small money, he takes all the coins and throws them into a piggy-bank. You know that this process is irreversible, the coins cannot be removed without breaking the pig. After a sufficiently long time, there should be enough cash in the piggy-bank to pay everything that needs to be paid.

But there is a big problem with piggy-banks. It is not possible to determine how much money is inside. So we might break the pig into pieces only to find out that there is not enough money. Clearly, we want to avoid this unpleasant situation. The only possibility is to weigh the piggy-bank and try to guess how many coins are inside. Assume that we are able to determine the weight of the pig exactly and that we know the weights of all coins of a given currency. Then there is some minimum amount of money in the piggy-bank that we can guarantee. Your task is to find out this worst case and determine the minimum amount of cash inside the piggy-bank. We need your help. No more prematurely broken pigs!

Input
The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing two integers E and F. They indicate the weight of an empty pig and of the pig filled with coins. Both weights are given in grams. No pig will weigh more than 10 kg, that means 1 <= E <= F <= 10000. On the second line of each test case, there is an integer number N (1 <= N <= 500) that gives the number of various coins used in the given currency. Following this are exactly N lines, each specifying one coin type. These lines contain two integers each, Pand W (1 <= P <= 50000, 1 <= W <=10000). P is the value of the coin in monetary units, W is it’s weight in grams.

Output
Print exactly one line of output for each test case. The line must contain the sentence “The minimum amount of money in the piggy-bank is X.” where X is the minimum amount of money that can be achieved using coins with the given total weight. If the weight cannot be reached exactly, print a line “This is impossible.”.

Sample Input
3
10 110
2
1 1
30 50
10 110
2
1 1
50 30
1 6
2
10 3
20 4

Sample Output
The minimum amount of money in the piggy-bank is 60.
The minimum amount of money in the piggy-bank is 100.
This is impossible.

完全背包问题,与01背包不同的是,完全背包要求的就是背包必须完全装满,例如本题的第一个例子,存钱罐不装钱重量是10,装完是110,所以里面的所装的前的重量就是100,不能多也不能少,并且,完全背包有个特点,就是东西都是无限的,就像本题的货币,不限量,在动态规划过程中,dp需要从小到大遍历,具体分析在代码部分讲解

代码如下:

#include<iostream>
#include<cstring>
#include<stdio.h>
using namespace std;
int main()
{
    int T;
    int start,now; //声明存钱罐原先的重量和现在的重量
    int N;  //货币的种类
    int value[509],weight[509],dp[10009];//分别代表货币的价值,货币的重量,动态规划背包重量所能装的最小价值
    int temp;//中间变量
    
    cin>>T;
    while(T--)
    {
    	//输入
        cin>>start>>now;
        cin>>N;
        
        for(int i=1;i<=N;i++){
            cin>>value[i]>>weight[i];
        }
        
        //memset(dp,0x3f,sizeof(dp)指的是把dp这个数组的每一个字节都变成0x3f,而每个字节的最大值是0x3f,所以这行代码
        代表的是把dp数组变得最大
        memset(dp,0x3f,sizeof(dp));
        dp[0]=0;//同时把dp[0]变成0,下面能起到一个关键的作用
       
        for(int i=1;i<=N;i++){     //遍历每一种货币
            for(int j=weight[i];j<=now-start;j++){      
            
				 temp=value[i]+dp[j-weight[i]];
                
                if(temp>0)
                if(temp<dp[j])
                dp[j]=temp;
                
            }
        }
        /*“ temp=value[i]+dp[j-weight[i]];“,value[i]是当前货币的价值,这个货币的重量是weight[i],
        dp[j-weight[i]]的意义是当前存钱罐中钱的重量为  j   ,dp[j-weight[i]]表示剩下的重量在之前所能代
        表的最小价值
        在上面的代码中初始化dp时,其他都是最大,唯独dp[0]=0,原因就是,假如有一块钱的货币重量为1,那么
        dp[0]=0,dp[1]=value[1]+dp[0], dp[0]的用处便是可以在遍历过程中减少麻烦
        而为什么要判断temp>0呢?开头也说过初始化dp,把它变成一个最大的数,只要这个数加上另一个大于零的数,
        那么结果就会溢出,变成一个负数。这一步的所用就在于,假如当前遍历的货币是1,重量是2,且只有这一种
        货币,那么遍历是从2开始的,当运算到dp[3]时,dp[3]=1+dp[1];算出的结果dp[3]等于一个最大数加上1,
        溢出,变成一个最小数。
        而 if(temp<dp[j])则是判断假如当前的货币,假如实际价值更小,则替换。因为结果是要输出存钱罐里最少有多少钱
        */
//假如最终dp[now-start]==dp[10008]  ,则代表找不到能匹配的货币
        if(dp[now-start]==dp[10008]){
        	
            cout<<"This is impossible."<<endl;
            
        }
        else
        {
        	//输出结果
            printf("The minimum amount of money in the piggy-bank is %d.\n",dp[now-start]);
        
		}
    }
} 
  • 1
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
信息数据从传统到当代,是一直在变革当中,突如其来的互联网让传统的信息管理看到了革命性的曙光,因为传统信息管理从时效性,还是安全性,还是可操作性等各个方面来讲,遇到了互联网时代才发现能补上自古以来的短板,有效的提升管理的效率和业务水平。传统的管理模式,时间越久管理的内容越多,也需要更多的人来对数据进行整理,并且数据的汇总查询方面效率也是极其的低下,并且数据安全方面永远不会保证安全性能。结合数据内容管理的种种缺点,在互联网时代都可以得到有效的补充。结合先进的互联网技术,开发符合需求的软件,让数据内容管理不管是从录入的及时性,查看的及时性还是汇总分析的及时性,都能让正确率达到最高,管理更加的科学和便捷。本次开发的医院后台管理系统实现了病房管理、病例管理、处方管理、字典管理、公告信息管理、患者管理、药品管理、医生管理、预约医生管理、住院管理、管理员管理等功能。系统用到了关系型数据库中王者MySql作为系统的数据库,有效的对数据进行安全的存储,有效的备份,对数据可靠性方面得到了保证。并且程序也具备程序需求的所有功能,使得操作性还是安全性都大大提高,让医院后台管理系统更能从理念走到现实,确确实实的让人们提升信息处理效率。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值