动态规划题目一

本文提供了5道动态规划练习题目,包括Max Sum Plus Plus、主元素问题、猴子和香蕉问题、超级跳跃游戏和存钱罐问题。每道题目详细描述了问题背景、输入输出格式,并给出了样例输入和输出。通过解决这些问题,可以加深对动态规划的理解和应用。
摘要由CSDN通过智能技术生成

动态规划练习题一

A - Max Sum Plus Plus

Problem Description
Now I think you have got an AC in Ignatius.L’s “Max Sum” problem. To be a brave ACMer, we always challenge ourselves to more difficult problems. Now you are faced with a more difficult problem.

Given a consecutive number sequence S1, S2, S3, S4 … Sx, … Sn (1 ≤ x ≤ n ≤ 1,000,000, -32768 ≤ Sx ≤ 32767). We define a function sum(i, j) = Si + … + Sj (1 ≤ i ≤ j ≤ n).

Now given an integer m (m > 0), your task is to find m pairs of i and j which make sum(i1, j1) + sum(i2, j2) + sum(i3, j3) + … + sum(im, jm) maximal (ix ≤ iy ≤ jx or ix ≤ jy ≤ jx is not allowed).

But I’m lazy, I don’t want to write a special-judge module, so you don’t have to output m pairs of i and j, just output the maximal summation of sum(ix, jx)(1 ≤ x ≤ m) instead.

Input
Each test case will begin with two integers m and n, followed by n integers S1, S2, S3 … Sn.
Process to the end of file.

Output
Output the maximal summation described above in one line.

Sample Input
1 3 1 2 3
2 6 -1 4 -2 3 -2 3

Sample Output
6
8

Hint
Huge input, scanf and dynamic programming is recommended.

#include <cstdio>
#include <algorithm>
#include <cstring>

using namespace std;
const int N = 1e6 + 10;
int a[N];
int dp[N];
int M[N];
int sum[N];
int n, m, ans;

int main() {
   
    while (scanf("%d%d", &m, &n) != EOF) {
   
        for (int i = 1; i <= n; ++i) {
   
            scanf("%d", &a[i]);
        }
        memset(sum, 0, sizeof(sum));
        memset(dp, 0, sizeof(dp));
        memset(M, 0, sizeof(M));
        for (int i = 1; i <= n; ++i) {
   
            sum[i] += sum[i - 1] + a[i];
        }
        for (int i = 1; i <= m; ++i) {
     //i组
            int maxj = sum[i];  //sum[i] 前i个数每个数为1组时的最大值
            ans = maxj; //前i个数分i组的最大值
            for (int j = i + 1; j <= n; ++j) {
   
                //maxj 以a[j]结尾分i组的最大值
                maxj = max(M[j - 1], maxj) + a[j];  //a[j]单独分一组 、a[j]加进第i组
                M[j - 1] = ans; //前j-1个数分i组的最大值
                ans = max(ans, maxj);   //更新ans为 前j个数分i组的最大值
            }
        }
        printf("%d\n", ans);
    }
    return 0;
}

B - Ignatius and the Princess IV

Problem Description
“OK, you a

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值