Prime Ring Problem

A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime. 

Note: the number of first circle should always be 1. 

 
Inputn (0 < n < 20). 
OutputThe output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order. 

You are to write a program that completes above process. 

Print a blank line after each case. 
Sample Input
6
8
Sample Output
Case 1:
1 4 3 2 5 6
1 6 5 2 3 4

Case 2:
1 2 3 8 5 6 7 4
1 2 5 8 3 4 7 6
1 4 7 6 5 8 3 2
1 6 7 4 3 8 5 2
#include <iostream>
#include <math.h>
using namespace std;
int arr[22];
int book[22];
int n,i=1;
bool isPrime(int x){
    if(x<2)
        return false;
    for(int i=2;i<=sqrt(x);i++){
        if(x%i==0)
            return false;
    }
    return true;
}

void dfs(int step){
    if(step==n&&isPrime(arr[1]+arr[n])){
        for(int i=1;i<n;i++)
            cout<<arr[i]<<" ";
        cout<<arr[n]<<endl;
        return;
    }
    else{
        for(int i=2;i<=n;i++){
            if(book[i]!=1&&isPrime(i+arr[step])){
                arr[step+1]=i;
                book[i]=1;
                dfs(step+1);
                book[i]=0;
            }
        }
    }
    return;
}
int main(){
    while(cin>>n){
        memset(book, 0, sizeof(book));
        arr[1]=1;
        
        cout<<"Case"<<" "<<i++<<":"<<endl;
        dfs(1);
        cout<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值