1155 Heap Paths (30 分)( BST+栈 )

In computer science, a heap is a specialized tree-based data structure that satisfies the heap property: if P is a parent node of C, then the key (the value) of P is either greater than or equal to (in a max heap) or less than or equal to (in a min heap) the key of C. A common implementation of a heap is the binary heap, in which the tree is a complete binary tree. (Quoted from Wikipedia at https://en.wikipedia.org/wiki/Heap_(data_structure))

One thing for sure is that all the keys along any path from the root to a leaf in a max/min heap must be in non-increasing/non-decreasing order.

Your job is to check every path in a given complete binary tree, in order to tell if it is a heap or not.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (1<N≤1,000), the number of keys in the tree. Then the next line contains N distinct integer keys (all in the range of int), which gives the level order traversal sequence of a complete binary tree.

Output Specification:

For each given tree, first print all the paths from the root to the leaves. Each path occupies a line, with all the numbers separated by a space, and no extra space at the beginning or the end of the line. The paths must be printed in the following order: for each node in the tree, all the paths in its right subtree must be printed before those in its left subtree.

Finally print in a line Max Heap if it is a max heap, or Min Heap for a min heap, or Not Heap if it is not a heap at all.

Sample Input 1:

8
98 72 86 60 65 12 23 50

Sample Output 1:

98 86 23
98 86 12
98 72 65
98 72 60 50
Max Heap

Sample Input 2:

8
8 38 25 58 52 82 70 60

Sample Output 2:

8 25 70
8 25 82
8 38 52
8 38 58 60
Min Heap

Sample Input 3:

8
10 28 15 12 34 9 8 56

Sample Output 3:

10 15 8
10 15 9
10 28 34
10 28 12 56
Not Heap

从右向左建树,判断从根节点到每一个叶结点的路径是否都满足>=或<=

路径拿栈记录,递归往上返回一次退栈一个元素,递归碰到叶结点时输出栈中内容

注意递归多个出口时一定要把判断叶结点为空这个条件放在最开始!

代码:

#include <iostream>
#include <stdlib.h>
#include <stdio.h>
#include <string>
#include <string.h>
#include <vector>
#include <stack>
#include <queue>
#include <map>

using namespace std;

int res[1002];
int tail = 0,rear = -1;
int ans[1002];
int ansRear = 0;
int tans;
typedef struct Node{
    struct Node* left_ptr;
    struct Node* right_ptr;
    int index;
    int data;
}BinNode,*BinTree;

void newNode(BinTree *node, int data, int index){
    *node = (BinTree)malloc(sizeof(BinNode));
    (*node)->data = data;
    (*node)->index = index;
    (*node)->left_ptr = NULL;
    (*node)->right_ptr = NULL;
}

void insertNode(BinTree *node, int data, int index){
    if(*node == NULL)
        return;
    if((index/2) == ((*node)->index)){
        if((*node)->right_ptr == NULL)
            newNode(&((*node)->right_ptr), data, index);
        else if((*node)->left_ptr == NULL)
            newNode(&((*node)->left_ptr), data, index);
        return;
    }
    insertNode(&((*node)->right_ptr), data, index);
    insertNode(&((*node)->left_ptr), data, index);
}

int check(){
    int flag = -1;  //1 minheap 2 maxheap 0 notheap
    for(int i = tail; i < rear; i++){
        if(res[i] >= res[i+1])
            continue;
        else{
            flag = 0;
            break;
        }
    }
    if(flag == -1)
        return flag = 2;
    if(flag == 0){
        for(int i = tail; i < rear; i++){
            if(res[i] <= res[i+1])
                continue;
            else
                return flag = 0;
        }
    }
    if(flag == 0)
        return flag = 1;
}

void printRes(){
    for(int i = tail; i < rear; i++)
        cout<<res[i]<<" ";
    cout<<res[rear]<<endl;
    tans = check();
    ans[ansRear++] = tans;
}

void travelTree(BinTree root){
    if(root == NULL)
        return;
    res[++rear] = root->data;
    if((root->left_ptr == NULL)&&(root->right_ptr == NULL)){
        printRes();
        --rear;
        return;
    }
    travelTree(root->left_ptr);
    travelTree(root->right_ptr);
    --rear;
}
int main()
{
    BinTree root = NULL;
    int n,temp;
    cin>>n;
    cin>>temp;
    root = (BinTree)malloc(sizeof(BinNode));
    root->data = temp;
    root->index = 1;
    root->left_ptr = NULL;
    root->right_ptr = NULL;
    for(int i = 2; i <= n; i ++){
        cin>>temp;
        insertNode(&root, temp, i);
    }
    travelTree(root);
    int mark = ans[0];

    for(int i=0;i<ansRear;i++){
        if(ans[i] == 0){
            cout<<"Not Heap";
            return 0;
        }
        if(ans[i] == mark)
            continue;
        else{
            cout<<"Not Heap";
            return 0;
        }
    }
    if(mark == 1)
        cout<<"Min Heap";
    else if(mark == 2)
        cout<<"Max Heap";
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值