使用idea和gradle编译spring5.2.x源码

最近在研究spring源码的时候,突然想起编译一下spring源码,网上应该也有很多大神编译过spring源码,在这里我把我再编译过程的遇到的坑,来跟大家分享下。 

1、下载gradle,可以去官网下载,gradle版本需要4.2以上,小编这里选择的是gradle5.6.4版本,下面我会说明为什么选择5.6.4版本。

gradle下载地址:https://services.gradle.org/distributions/

gradle-5.6.4-src.zip 源码

gradle-5.6.4-bin.zip 安装文件

gradle-5.6.4-all.zip  源码+安装文件

1、我下载的是gradle-5.6.4-bin.zip安装文件,解压到指定目录下,然后配置环境变量

2、配置完成环境变量后,查看gradle是否生效和安装版本

 3、下载spring源码

https://github.com/spring-projects/spring-framework

下载想要编译的源码,下载。

注意:上图标红位置,进入目录,spring-framework/gradle/wrapper/下,查看gradle-wrapper.properties配置文件。

 gradle对应的版本正好是我选择gradle5.6.4版本,如果版本不一致可能会导入spring源码编译失败,你查网上帖子说的是jdk编译问题,其实是因为没有安装对应gradle版本编译出现的各种错误,至于编译其他spring源码,以此类推都可编译成功,本人亲测。

已标记关键词 清除标记
相关推荐
©️2020 CSDN 皮肤主题: 大白 设计师:CSDN官方博客 返回首页