干勾鱼的CSDN博客

安悦轻阅:AYQY.com,打造安心愉悦的轻阅读!

Eclipse运行tomcat出现错误“An incompatible version [1.1.33] of the APR based。。。 ”问题的解决

转载请注明出处:http://blog.csdn.net/dongdong9223/article/details/80009634
本文出自【我是干勾鱼的博客

使用Eclipse运行tomcat时,有时会出现出现错误:

四月 19, 2018 6:52:08 下午 org.apache.catalina.core.AprLifecycleListener init
严重: An incompatible version [1.1.33] of the APR based Apache Tomcat Native library is installed, while Tomcat requires version [1.2.14]

如下图所示:

这里写图片描述

当然我们可以到相应的官网去下载一个文件,解压之后找到dll文件(tcnative-1.dll)放到系统的“System32”目录下,其实如果深究问题原因会发现其实是:

。。。有这个问题主要还是因为Eclipse自带的wtp的插件没支持到最新的tomcat7导致的。。。tomcat/bin下明明有个文件,并且已经是最新的,为什么还要在别的地方乱扔一个。。。

所以有一个很简单的解决办法,即在eclipse中给tomcat的启动加一个参数,点击eclipse上方按钮:

Run as -> Run Configurations…

如图所示:

这里写图片描述

然后添加启动参数:

-Djava.library.path="E:\Studying\tomcat\apache-tomcat-8.5.30\bin"

也就是添加一个tomcat里bin目录的路径,如图所示:

这里写图片描述

确定之后,再重新启动tomcat,错误就没有了。

阅读更多
版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/dongdong9223/article/details/80009634
个人分类: Web工程
想对作者说点什么? 我来说一句

没有更多推荐了,返回首页

加入CSDN,享受更精准的内容推荐,与500万程序员共同成长!
关闭
关闭