HDU 4662 MU Puzzle

3 篇文章 0 订阅

MU Puzzle

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 81    Accepted Submission(s): 44


Problem Description
Suppose there are the symbols M, I, and U which can be combined to produce strings of symbols called "words". We start with one word MI, and transform it to get a new word. In each step, we can use one of the following transformation rules:
1. Double any string after the M (that is, change Mx, to Mxx). For example: MIU to MIUIU.
2. Replace any III with a U. For example: MUIIIU to MUUU.
3. Remove any UU. For example: MUUU to MU.
Using these three rules is it possible to change MI into a given string in a finite number of steps?
 

Input
First line, number of strings, n. 
Following n lines, each line contains a nonempty string which consists only of letters 'M', 'I' and 'U'. 

Total length of all strings <= 10 6.
 

Output
n lines, each line is 'Yes' or 'No'.
 

Sample Input
  
  
2 MI MU
 

Sample Output
  
  
Yes No
 

Source
 

Recommend
zhuyuanchen520
 
题意:  
1、Mx -> Mxx
2、III -> U
3、UU -> 空
问MI 能否进过上面操作转化成  读入的字符串。

思路:模拟
根据3个操作可知:
1、M前面的不能有字母。
2、只能有一个M
3、操作一只能得到 2^n个I (n > 0)
4、可以消去6个I.
然后得到一个公式  2^n - 6 * m = sum; (sum 表示读入的字符串中I的个数);

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
#include <vector>
#include <cmath>
using namespace std;

//

const int V = 1000000 + 50;
const int MaxN = 80 + 5;
const int mod = 10000 + 7;
const __int64 INF = 0x7FFFFFFFFFFFFFFFLL;
const int inf = 0x7fffffff;
int n, flag;
char ch[V];
int main() {
    int i, j;
    scanf("%d", &n);
    while(n--) {
        flag = 1;
        scanf("%s", &ch);
        if(ch[0] != 'M')
            printf("No\n");
        else{
            int sum = 0;
            for(i = 1; ch[i]; ++i) {
                if(ch[i] == 'M') {
                    flag = 0;
                    break;
                }
                else if(ch[i] == 'U')
                    sum += 3;
                else
                    sum ++;
            }
            if(!flag) {
                printf("No\n");
                continue;
            }
            if(sum == 1) {
                printf("Yes\n");
                continue;
            }
            if(sum % 2 == 1) {
                printf("No\n");
                continue;
            }
            for(i = 25; i >= 0; --i) {
                if(((1 << i) - sum % 6) == 0) {
                    flag = 0;
                    break;
                }
            }
            if(flag)
                printf("No\n");
            else
                printf("Yes\n");
        }
    }
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值