HDU 4632 Palindrome subsequence

Palindrome subsequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/65535 K (Java/Others)
Total Submission(s): 287    Accepted Submission(s): 86


Problem Description
In mathematics, a subsequence is a sequence that can be derived from another sequence by deleting some elements without changing the order of the remaining elements. For example, the sequence <A, B, D> is a subsequence of <A, B, C, D, E, F>.
(http://en.wikipedia.org/wiki/Subsequence)

Given a string S, your task is to find out how many different subsequence of S is palindrome. Note that for any two subsequence X = <S x1, S x2, ..., S xk> and Y = <S y1, S y2, ..., S yk> , if there exist an integer i (1<=i<=k) such that xi != yi, the subsequence X and Y should be consider different even if S xi = S yi. Also two subsequences with different length should be considered different.
 

Input
The first line contains only one integer T (T<=50), which is the number of test cases. Each test case contains a string S, the length of S is not greater than 1000 and only contains lowercase letters.
 

Output
For each test case, output the case number first, then output the number of different subsequence of the given string, the answer should be module 10007.
 

Sample Input
  
  
4 a aaaaa goodafternooneveryone welcometoooxxourproblems
 

Sample Output
  
  
Case 1: 1 Case 2: 31 Case 3: 421 Case 4: 960
 

Source
 

Recommend
zhuyuanchen520
 
题意: 有一个字符串, 问回文子序列的个数。

思路: DP
dp[i][j]表示 [i, j]的回文串的数量
要自己递推下。
给个表
a a b  a  c
1 3 4 1011
0 1 2  5  6
0 0 1 2 3
0 0 0 1 2
0 0 0 0 1

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
#include <vector>
using namespace std;

//

const int V = 1000 + 50;
const int MaxN = 80 + 5;
const int mod = 10000 + 7;
char ch[V];
int T, dp[V][V];
int main() {
    int i, j, c = 1;
    scanf("%d", &T);
    while(T--) {
        scanf("%s", &ch);
        int len = strlen(ch);
        memset(dp, 0, sizeof(dp));
        for(i = 0; i < len; ++i)
            dp[i][i] = 1;
        for(i = 1; i < len; ++i)
            for(j = 0; i + j < len; ++j) {
                if(ch[j] != ch[i + j])
                    dp[j][i + j] = dp[j + 1][i + j] + dp[j][i + j - 1] - dp[j + 1][i + j - 1];
                else
                    dp[j][i + j] = dp[j + 1][i + j] + dp[j][i + j - 1] + 1;
                dp[j][i + j] = (dp[j][i + j] + mod) % mod;
            }
        printf("Case %d: %d\n", c++, dp[0][len - 1]);
    }
}


评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值