HDU 6227 Rabbits 找规律

HDU 6227 Rabbits

Problem Description
Here N (N ≥ 3) rabbits are playing by the river. They are playing on a number line, each occupying a different integer. In a single move, one of the outer rabbits jumps into a space between any other two. At no point may two rabbits occupy the same position.
Help them play as long as possible

Input
The input has several test cases. The first line of input contains an integer t (1 ≤ t ≤ 500) indicating the number of test cases.
For each case the first line contains the integer N (3 ≤ N ≤ 500) described as above. The second line contains n integers a1 < a2 < a3 < … < aN which are the initial positions of the rabbits. For each rabbit, its initial position
ai satisfies 1 ≤ ai ≤ 10000.

Output
For each case, output the largest number of moves the rabbits can make.

Sample Input
5
3
3 4 6
3
2 3 5
3
3 5 9
4
1 2 3 4
4
1 2 4 5

Sample Output
1
1
3
0
1



简要题意

一排兔子在一条坐标轴上, 两边的要往中间的空里跳(比如1 2 4上有三只兔子, 那么1可以跳到3的位置), 求最大的跳跃次数 (没空了)


题目分析

算是一道找规律的题吧, 重点在于
1.空的个数–z
2.兔子的个数–n
3.最左端和最右端的空的大小–l,r
这里设第一只兔子坐标为x, 最后一只兔子坐标为y, 则
空的个数 z == y - x + 1 - n
结果 k == z - min{ l ,r }


代码

#include<stdio.h>

int a[10100];
//int max = 0, min = 99999; 默认升序 
int min( int x, int y);
int main(void)
{
	int t;	//数据数量t
	scanf("%d", &t);
	while( t--)
	{
		int n;	//每组数据中兔子的总数n
		int i, l, r, z, k;	
		scanf("%d", &n);
		for( i=1; i<=n; i++)
		{
			scanf("%d", &a[i]);
		}
		z = a[n] - a[1] + 1 - n;	//空数z
		l = a[2] - a[1] - 1;		//最左边空的大小l
		r = a[n] - a[n-1] - 1;		//最右边空的大小r
		k = z - min(l,r);			//结果
		printf("%d\n", k);
	}
	return 0;
}

int min(int x, int y)
{
	int z;
	if(x>y)	z = y;
	else	z = x;
	return z;
}

收获与反思

  1. 在C语言中, 判断两数大小的函数可以用一步三目运算符xx?xx:xx来实现
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值