hud 6227 Rabbits

Rabbits

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 439    Accepted Submission(s): 256


Problem Description
Here N (N ≥ 3) rabbits are playing by the river. They are playing on a number line, each occupying a different integer. In a single move, one of the outer rabbits jumps into a space between any other two. At no point may two rabbits occupy the same position.
Help them play as long as possible
 

Input
The input has several test cases. The first line of input contains an integer t (1 ≤ t ≤ 500) indicating the number of test cases.
For each case the first line contains the integer N (3 ≤ N ≤ 500) described as above. The second line contains n integers  a1  <  a2  <  a3  < ... <  aN  which are the initial positions of the rabbits. For each rabbit, its initial position
ai  satisfies 1 ≤  ai  ≤ 10000.
 

Output
For each case, output the largest number of moves the rabbits can make.
 

Sample Input
  
  
5 3 3 4 6 3 2 3 5 3 3 5 9 4 1 2 3 4 4 1 2 4 5
 

Sample Output
  
  
1 1 3 0 1
 

Source
 

Recommend
jiangzijing2015   |   We have carefully selected several similar problems for you:   6229  6228  6227  6226  6225 


代码:
#include<iostream>
#include<algorithm>
using namespace std;
int main()
{
    int t,n,a[510],b[510],x;
    cin>>t;
    while(t--)
    {
        int sum=0;
        cin>>n;
        for(int i=0;i<n;i++)
            cin>>a[i];
        for(int i=0;i<n-1;i++)
        {
            b[i]=a[i+1]-a[i]-1;
            sum+=b[i];
        }
        x=min(b[0],b[n-2]);
        cout<<sum-x<<endl;
    }
    return 0;
}


刚开始看错题意了。这里说的外边是指 最外边两个数!!!

如: 1  2   3  4  5   6  7  8  9  10   11
1->(3,11):2+4=6;
11->(1,6):1+2=3;
不能取3和6!!!


 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值