poj 2533 最长上升子序列

Longest Ordered Subsequence

        Time Limit: 2000MS      Memory Limit: 65536K
            Total Submissions: 58233        Accepted: 26082
Description

A numeric sequence of ai is ordered if a1 < a2 < … < aN. Let the subsequence of the given numeric sequence (a1, a2, …, aN) be any sequence (ai1, ai2, …, aiK), where 1 <= i1 < i2 < … < iK <= N. For example, sequence (1, 7, 3, 5, 9, 4, 8) has ordered subsequences, e. g., (1, 7), (3, 4, 8) and many others. All longest ordered subsequences are of length 4, e. g., (1, 3, 5, 8).

Your program, when given the numeric sequence, must find the length of its longest ordered subsequence.

Input

The first line of input file contains the length of sequence N. The second line contains the elements of sequence - N integers in the range from 0 to 10000 each, separated by spaces. 1 <= N <= 1000

Output

Output file must contain a single integer - the length of the longest ordered subsequence of the given sequence.

Sample Input

7
1 7 3 5 9 4 8

Sample Output

4

Source

Northeastern Europe 2002, Far-Eastern Subregion

解析:
这是一个动态规划的题目,解决的关键就在于找出一个无后效性的状态值。把每个数作为最长子序列的”终点“,这个终点包含在最长子序列当中。当把下一个数作为终点的时候,只要考虑前面的每个数作为最长子序列的值就好了。

#include <iostream>
#include <algorithm>
using namespace std;

int n;
int src[1000];
int maxLen[1000];
void f(int k){
    int max = 1;
    for(int i = 0;i < k; ++i){
        if(src[i] < src[k] ){
            if(maxLen[i] + 1 > max){
                max = maxLen[i] + 1;
            }
        }
    }

    maxLen[k] = max;
}
int main(){
    cin >> n;
    for(int i = 0;i < n; ++i){
        cin >> src[i] ;
        f(i);
    }

    cout << * max_element(maxLen,maxLen+n )<< endl;
    return 0;
}

中国大学mooc 程序设计与算法(二) 北京大学 郭炜

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值