Ordering Tasks

Description

John has n tasks to do. Unfortunately, the tasks are not independent and the execution of one task is only possible if other tasks have already been executed.

Input

The input will consist of several instances of the problem. Each instance begins with a line containing two integers, 1 <= n <= 100 andmn is the number of tasks (numbered from 1 to n) and m is the number of direct precedence relations between tasks. After this, there will be m lines with two integers i and j, representing the fact that task i must be executed before task j. An instance with n = m = 0will finish the input.

Output

For each instance, print a line with n integers representing the tasks in a possible order of execution.

Sample Input

5 4
1 2
2 3
1 3
1 5
0 0

Sample Output

1 4 2 5 3
这个问题是图论里面典型的“拓扑排序”,需要注意的一点是如果图中存在有向环则不存在拓扑排序,即有向无环图(DAG)才有拓扑排序。借助DFS完成拓扑排序。代码如下:
#include<cstdio>
#include<cstring>
using namespace std;

const int maxn=100+5;
int G[maxn][maxn],c[maxn],topo[maxn],t,n;

bool dfs(int u)
{
	c[u]=-1;
	for(int v=1;v<=n;v++)
	{
		if(G[u][v])
		{
			if(c[v]<0) return false;
			else if(!c[v]) dfs(v);
		}
	}
	c[u]=1;topo[- -t]=u;
	return true;
}
bool toposort()
{
	t=n;
	memset(c,0,sizeof(c));
	for(int u=1;u<=n;u++)
	{
		if(!c[u])
		{
			if(!dfs(u)) return false;
		}
	}
	return true;
}
int main()
{
	int m;
	while(scanf("%d%d",&n,&m)==2&&(m||n))
	{
		memset(G,0,sizeof(G));
		for(int i=0;i<m;i++)
		{
			int u,v;
			scanf("%d%d",&u,&v);
			G[u][v]=1;
		}
		if(toposort())
		{
			for(int i=0;i<=n-1;i++)
				printf("%d ",topo[i]);
			printf("\n");
		}
		else
			printf("No\n");
	}
	return 0;
}

这倒题的拓扑排序是借助数组来做的:
1.G【i】【j】=1表示有从i到j的一条有向边。
2.因为这不像树一样有根结点,所以我们是按照从1~n的顺序进行DFS的。
3.c【】是一个很重要的数组,若c【i】=0表示i还没有搜索过,若c【i】=-1表示正在搜索i的后序结点,若c【i】=1表示i已经被搜索过。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值