SDUT2132--一般算术表达式转换成后缀式

Problem Description

对于一个基于二元运算符的算术表达式,转换为对应的后缀式,并输出之。

input

输入一个算术表达式,以‘#’字符作为结束标志。

Output

输出该表达式转换所得到的后缀式。

Example Input

a*b+(c-d/e)*f#

Example Output

ab*cde/-f*+

思路

栈的基本运算。 两个栈,一个存放运算符,另一个存放后缀表达式
当字符为运算数的时候,直接进如postexp栈
当字符为‘(’时入栈optr
当字符为“-,+”时,弹出前面所有的“+,-,*,/”运算符直到栈optr为空或者遇到‘(’
当字符为“/,* ”,弹出前面所有的“*,/”运算符直到栈optr为空或者遇到‘(’
当字符为‘)’时,弹出前面所有的“+,-,*,/”运算符直到栈optr为空或者遇到‘(’弹出‘(’。

#include <cstdio>
#include <iostream>
#include <algorithm>
#include <stack>
#include <cstring>
using namespace std;
stack<char>optr;    //运算符栈
stack<char>postexp; //后缀表达式栈
char a[100];
int n;
void gao()
{
    for(int i = 0; i < n-1; i ++)
    {
        switch(a[i])
        {
        case '+':
        case '-':
            while( !optr.empty() )
            {
                if( optr.top() == '(')
                    break;
                postexp.push( optr.top() );
                optr.pop();
            }
            optr.push(a[i]);
            break;
        case '*':
        case '/':
            while( !optr.empty() )
            {
                if( optr.top() == '(')
                {
                    break;
                }
                else if( optr.top() == '+' || optr.top() == '-')
                    break;
                postexp.push( optr.top() );
                optr.pop();
            }
            optr.push(a[i]);
            break;
        case '(':
            optr.push(a[i]);
            break;
        case ')':
            while( !optr.empty() )
            {
                if( optr.top() == '(')
                {
                    optr.pop();
                    break;
                }
                postexp.push( optr.top() );
                optr.pop();
            }
            break;
        default :
            postexp.push(a[i]);
        }
    }
    while( !optr.empty() )
    {
        postexp.push( optr.top() );
        optr.pop();
    }
    int i = 0;
    while( !postexp.empty() )
    {
        a[i++] = postexp.top();
        postexp.pop();
    }
    for(int j = i-1; j >= 0; j --)
        cout << a[j];
    cout << endl;
}
int main()
{
    cin >> a;
    n = strlen(a);
    gao();
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值