PAT日志 1002

顽强的小白

1002 A+B for Polynomials (25 分)

题目

This time, you are supposed to find A+B where A and B are two polynomials.

Input Specification:
Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 ​​ aN1​​ N2 ​ aN2​​​​ … ​where K is the number of nonzero terms in the polynomial, Ni​​ and aNi​​(i=1,2,⋯) are the exponents and coefficients, respectively. It is given that 1≤K≤10,0≤NK<⋯<N2<N1≤10000.

Output Specification:
For each test case you should output the sum of Aand B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input:
2 1 2.4 0 3.2
2 2 1.5 1 0.5
Sample Output:
3 2 1.5 1 2.9 0 3.2

题目内容
多项式相加

代码实现

#include <cstdio>
#include <string.h>
#include <algorithm>
using namespace std;
const int maxn=1005;
int main(){
 double A[maxn],B[maxn];
 fill(A,A+maxn,0);    //用fill函数初始化一下 
 fill(B,B+maxn,0);
 int k1,k2,ex;
 double co;
 scanf("%d",&k1);
 for(int i=0;i<k1;++i) {
  scanf("%d %lf",&ex,&co);
  A[ex]=co;
 }
 scanf("%d",&k2);
 for(int i=0;i<k2;++i) {
  scanf("%d %lf",&ex,&co);
  B[ex]=co;
 }
 int cnt=0;
 for(int i=0;i<maxn;++i){
  A[i]+=B[i];
  if(A[i]!=0) ++cnt; 
 }
 printf("%d",cnt);
 for(int i=maxn-1;i>=0;--i){
  if(A[i]!=0) printf(" %d %.1lf",i,A[i]);
 }
}

注意点

  • 没有需要太注意的,数据量不大,只需要对应项相加,输出的时候保留小数点
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值