PAT日志 1147 Heaps

顽强的小白

1147 Heaps (30 分)

In computer science, a heap is a specialized tree-based data structure that satisfies the heap property: if P is a parent node of C, then the key (the value) of P is either greater than or equal to (in a max heap) or less than or equal to (in a min heap) the key of C. A common implementation of a heap is the binary heap, in which the tree is a complete binary tree. (Quoted from Wikipedia at https://en.wikipedia.org/wiki/Heap_(data_structure))
Your job is to tell if a given complete binary tree is a heap.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers: M (≤ 100), the number of trees to be tested; and N (1 < N ≤ 1,000), the number of keys in each tree, respectively. Then M lines follow, each contains N distinct integer keys (all in the range of int), which gives the level order traversal sequence of a complete binary tree.

Output Specification:

For each given tree, print in a line Max Heap if it is a max heap, or Min Heap for a min heap, or Not Heap if it is not a heap at all. Then in the next line print the tree’s postorder traversal sequence. All the numbers are separated by a space, and there must no extra space at the beginning or the end of the line.

Sample Input:

3 8
98 72 86 60 65 12 23 50
8 38 25 58 52 82 70 60
10 28 15 12 34 9 8 56

Sample Output:

Max Heap
50 60 65 72 12 23 86 98
Min Heap
60 58 52 38 82 70 25 8
Not Heap
56 12 34 28 9 8 15 10

题目解析

判断是大根堆还是小根堆 输出后序遍历
基本这种题目都是要综合一下的,后序遍历递归写就好了
堆的储存可以存到一维数组中,判断大根还是小根可以同时进行,也是递归。

代码实现

#include <cstdio>
#include <algorithm>
using namespace std;
const int maxn=1005;
int a[maxn];
int m,n;
int judge(int root){
 if(root>n) return 0;
 int l,r,tag;
 l=judge(root*2);
 r=judge(root*2+1);
 if(root*2+1<=n){            //两个孩子 
  if(a[root]>a[root*2]&&a[root]>a[root*2+1]){
   tag=1;
  }else if(a[root]<a[root*2]&&a[root]<a[root*2+1]){
   tag= -1;
  }else tag=3;
  if(tag==1&&(l==1||l==0)&&(r==1||r==0)) return 1;
  else if(tag==-1&&(l==-1||l==0)&&(r==-1||r==0)) return -1;
  else return 3; 
 }else if(root*2<=n){      //一个孩子 
  if(a[root]>a[root*2]) tag=1;
  else if(a[root]<a[root*2]) tag=-1;
  if(tag==1&&(l==1||l==0)) return 1;
  else if(tag==-1&&(l==-1||l==0)) return -1;
  else return 3;
 }else return 0;      //没有孩子 
}

int cnt=0;
void postOrder(int root){
 if(root>n) return ;
 postOrder(root*2);
 postOrder(root*2+1);
 printf("%d",a[root]);
 cnt++;
 if(cnt<n)printf(" ");
 else printf("\n");
}
int main(){
 scanf("%d%d",&m,&n);
 for(int i=0;i<m;++i){
  for(int j=1;j<=n;++j){
   scanf("%d",&a[j]);
  }
  int ans=judge(1);
  if(ans==1)printf("Max Heap\n");
  else if(ans==-1) printf("Min Heap\n");
  else printf("Not Heap\n");
  postOrder(1);
  cnt=0;
  
 }
 return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值