PAT日志 1075

顽强的小白

1075 PAT Judge (25 分)

The ranklist of PAT is generated from the status list, which shows the scores of the submissions. This time you are supposed to generate the ranklist for PAT.

Input Specification:

Each input file contains one test case. For each case, the first line contains 3 positive integers, N (≤10​4​​), the total number of users, K (≤5), the total number of problems, and M (≤10​5​​), the total number of submissions. It is then assumed that the user id’s are 5-digit numbers from 00001 to N, and the problem id’s are from 1 to K. The next line contains K positive integers p[i] (i=1, …, K), where p[i] corresponds to the full mark of the i-th problem. Then M lines follow, each gives the information of a submission in the following format:
user_id problem_id partial_score_obtained
where partial_score_obtained is either −1 if the submission cannot even pass the compiler, or is an integer in the range [0, p[problem_id]]. All the numbers in a line are separated by a space.

Output Specification:

For each test case, you are supposed to output the ranklist in the following format:
rank user_id total_score s[1] … s[K]
where rank is calculated according to the total_score, and all the users with the same total_score obtain the same rank; and s[i] is the partial score obtained for the i-th problem. If a user has never submitted a solution for a problem, then “-” must be printed at the corresponding position. If a user has submitted several solutions to solve one problem, then the highest score will be counted.
The ranklist must be printed in non-decreasing order of the ranks. For those who have the same rank, users must be sorted in nonincreasing order according to the number of perfectly solved problems. And if there is still a tie, then they must be printed in increasing order of their id’s. For those who has never submitted any solution that can pass the compiler, or has never submitted any solution, they must NOT be shown on the ranklist. It is guaranteed that at least one user can be shown on the ranklist.

Sample Input:

7 4 20
20 25 25 30
00002 2 12
00007 4 17
00005 1 19
00007 2 25
00005 1 20
00002 2 2
00005 1 15
00001 1 18
00004 3 25
00002 2 25
00005 3 22
00006 4 -1
00001 2 18
00002 1 20
00004 1 15
00002 4 18
00001 3 4
00001 4 2
00005 2 -1
00004 2 0

Sample Output:

1 00002 63 20 25 - 18
2 00005 42 20 0 22 -
2 00007 42 - 25 - 17
2 00001 42 18 18 4 2
5 00004 40 15 0 25 -

题目解析

题目大意是模仿PAT判定机制,根据提交的最高分为最终成绩。
其中的要求:

  • 可以有多次提交,按最高成绩来
  • 最终排序时只需要输出有通过编译的(任何题目都可以)学生的成绩
  • 按照总分高低输出 并且有排名
  • 如果分数一致,就按照满分的题目道数排序
  • 如果仍然一致,就按学号从小到大
  • 如果没有通过编译,输出0
  • 如果没有提交过输出 “-”

代码实现

细心细心,注意学生编号和题目编号问题都是从1开始
此次初始化的内容比较多,要求繁琐,容易出错

#include <cstdio>
#include <algorithm>
#include <cstring>
using namespace std;
const int maxn=10010;
struct Student{
 int id;
 int gade[6];
 bool flag;    //标记是否有通过编译的题目
 int score_all;
 int solve; 
}stu[maxn];
int n,k,m;
int full[6];
void init(){
 for(int i=1;i<=n;++i){
  stu[i].id =i;
  stu[i].score_all=0;
  stu[i].solve=0;
  stu[i].flag=false;
  memset(stu[i].gade,-1,sizeof(stu[i].gade));
 }
}
bool cmp(Student a,Student b){
 if(a.score_all!=b.score_all) return a.score_all>b.score_all;
 else if(a.solve!=b.solve) return a.solve>b.solve;
 else return a.id<b.id;
}
int main(){
 scanf("%d%d%d",&n,&k,&m);
 init();
 for(int i=1;i<=k;++i){
  scanf("%d",&full[i]);
 }
 int tag,score,id;
 for(int i=0;i<m;++i){
  scanf("%d %d %d",&id,&tag,&score);
  if(score!=-1){
   stu[id].flag=true;
  }
  if(score==-1&&stu[id].gade[tag]==-1){
   stu[id].gade[tag]=0;          //区别于没有提交过的 
  }
     if(score==full[tag]&&stu[id].gade [tag]<full[tag]){
   stu[id].solve++;    //注意提交次数有多次 
  }
  if(stu[id].gade [tag]<score) {
   stu[id].gade[tag]=score; 
  }
 }
 for(int i=1;i<=n;++i){
  for(int j=1;j<=k;++j){
   if(stu[i].gade[j]!=-1){
    stu[i].score_all+=stu[i].gade[j]; 
   }
   
  }
 }
 sort(stu+1,stu+1+n,cmp);
 int r=1;
 for(int i=1;i<=n;++i){
  if(stu[i].flag){
   if(i>1&&stu[i].score_all!=stu[i-1].score_all){
    r=i;
   }
   printf("%d %05d %d",r,stu[i].id,stu[i].score_all);
   for(int j=1;j<=k;++j){
    if(stu[i].gade[j]==-1){
     printf(" -") ;
    }else {
     printf(" %d",stu[i].gade[j]);
    }
   }
   printf("\n");
  }
 }
 return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值