PAT日志 1154

顽强的小白

1154 Vertex Coloring (25 分)

A proper vertex coloring is a labeling of the graph’s vertices with colors such that no two vertices sharing the same edge have the same color. A coloring using at most kkk colors is called a (proper) kkk-coloring.Now you are supposed to tell if a given coloring is a proper kkk-coloring.

Input Specification:E

ach input file contains one test case. For each case, the first line gives two positive integers N and M (both no more than 10^4​​), being the total numbers of vertices and edges, respectively. Then M lines follow, each describes an edge by giving the indices (from 0 to N−1) of the two ends of the edge.After the graph, a positive integer K (≤ 100) is given, which is the number of colorings you are supposed to check. Then K lines follow, each contains N colors which are represented by non-negative integers in the range of int. The i-th color is the color of the i-th vertex.

Output Specification:

For each coloring, print in a line k-coloring if it is a proper k-coloring for some positive k, or No if not.

Sample Input:

10 11
8 7
6 8
4 5
8 4
8 1
1 2
1 4
9 8
9 1
1 0
2 4
4
0 1 0 1 4 1 0 1 3 0
0 1 0 1 4 1 0 1 0 0
8 1 0 1 4 1 0 5 3 0
1 2 3 4 5 6 7 8 8 9

Sample Output:

4-coloring
No
6-coloring
No

题目解析

看了半天才明白,给一个图,每个顶点赋予不同的点权(颜色),判断这个图中有没有一条边的两端点权相等的(颜色一样),有的话,输出NO,否则输出,这组颜色的颜色种类数。

注意点:
  • 如果用二维数组暴力解决空间就不够用。后面我就用了容器vector来储存
  • 还有这个求颜色种类,我一开始在判断是否有边得情况下求的(这样会少算一些不成边的颜色),有一个点没过,后面改成了在输入点权的时候计算就对了。用set来储存点权最合适了,它会自动排除重复的选项。

代码实现

#include <cstdio>
#include <algorithm>
#include <set>
#include <vector> 
using namespace std;
const int maxn=10005;
vector<int> G[maxn];
set<int> ans;
int m,n,e;
int color[maxn];
void deal(){
 for(int i=0;i<maxn;++i){
  for(int j=0;j<G[i].size();++j){
   if(color[i]==color[G[i][j]]){
    printf("No\n");
    return;
   }
  }
 }
 printf("%d-coloring\n",ans.size());
}
int main(){
 int u,v;
 scanf("%d %d",&n,&e);
 for(int i=0;i<e;++i){
  scanf("%d%d",&u,&v);
  G[u].push_back(v);
  G[v].push_back(u);
 }
 scanf("%d",&m);
 for(int i=0;i<m;++i){
  ans.clear();
  for(int j=0;j<n;++j){
   scanf("%d",&color[j]);
   ans.insert(color[j]);
  }
  deal();
 }
 
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值