PAT-A1154 Vertex Coloring 题目内容及题解

A proper vertex coloring is a labeling of the graph's vertices with colors such that no two vertices sharing the same edge have the same color. A coloring using at most k colors is called a (proper) k-coloring.

Now you are supposed to tell if a given coloring is a proper k-coloring.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N and M (both no more than 10^​4​​), being the total numbers of vertices and edges, respectively. Then M lines follow, each describes an edge by giving the indices (from 0 to N−1) of the two ends of the edge.

After the graph, a positive integer K (≤ 100) is given, which is the number of colorings you are supposed to check. Then K lines follow, each contains N colors which are represented by non-negative integers in the range of int. The i-th color is the color of the i-th vertex.

Output Specification:

For each coloring, print in a line k-coloring if it is a proper k-coloring for some positive k, or No if not.

Sample Input:

10 11
8 7
6 8
4 5
8 4
8 1
1 2
1 4
9 8
9 1
1 0
2 4
4
0 1 0 1 4 1 0 1 3 0
0 1 0 1 4 1 0 1 0 0
8 1 0 1 4 1 0 5 3 0
1 2 3 4 5 6 7 8 8 9

Sample Output:

4-coloring
No
6-coloring
No

题目大意

恰当的顶点着色是用颜色标记图上的顶点,使共享同一条边的两个顶点不具有相同的颜色。使用最多k种颜色的着色称为(适当的)k着色。题目给定一个无向图,和若干组顶点的上色方案,要求判断每组上色方案是否是恰当的顶点上色方案,若是,其为几着色的方案。

解题思路

  1. 初始化并保存各边的端点信息;
  2. 对每组给定的上色方案进行读取,读取颜色序列并将颜色信息插入set容器中;
  3. 对各边进行检验,判断每条边两侧是否颜色不同,如遇相同则退出循环并输出不是恰当顶点着色;
  4. 如是顶点着色,则根据set容器的大小输出着色信息;
  5. 返回零值。

代码

#include<cstdio>
#include<set>
using namespace std;
#define maxn 10010

int test1[maxn],test2[maxn],seq[maxn];
set<int> st;
int N,M,K;


void Init(){
    int i;
    scanf("%d%d",&N,&M);
    for(i=0;i<M;i++){
        scanf("%d%d",&test1[i],&test2[i]);
    }
    scanf("%d",&K);
}

void Check(){
    int i;
    st.clear();
    for(i=0;i<N;i++){
        scanf("%d",&seq[i]);
        st.insert(seq[i]);
    }
    for(i=0;i<M;i++){
        if(seq[test1[i]]==seq[test2[i]]){
            printf("No\n");
            return;
        }
    }
    printf("%d-coloring\n",st.size());
    return;
}

int main(){
    Init();
    while(K--){
        Check();
    }
    return 0;
}

运行结果

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值