PAT甲级 -- 1155 Heap Paths (30 分)

In computer science, a heap is a specialized tree-based data structure that satisfies the heap property: if P is a parent node of C, then the key (the value) of P is either greater than or equal to (in a max heap) or less than or equal to (in a min heap) the key of C. A common implementation of a heap is the binary heap, in which the tree is a complete binary tree. (Quoted from Wikipedia athttps://en.wikipedia.org/wiki/Heap_(data_structure))

One thing for sure is that all the keys along any path from the root to a leaf in a max/min heap must be in non-increasing/non-decreasing order.

Your job is to check every path in a given complete binary tree, in order to tell if it is a heap or not.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (1<N≤1,000), the number of keys in the tree. Then the next line contains N distinct integer keys (all in the range of int), which gives the level order traversal sequence of a complete binary tree.

Output Specification:

For each given tree, first print all the paths from the root to the leaves. Each path occupies a line, with all the numbers separated by a space, and no extra space at the beginning or the end of the line. The paths must be printed in the following order: for each node in the tree, all the paths in its right subtree must be printed before those in its left subtree.

Finally print in a line Max Heap if it is a max heap, or Min Heap for a min heap, or Not Heap if it is not a heap at all.

Sample Input 1:

8
98 72 86 60 65 12 23 50

Sample Output 1:

98 86 23
98 86 12
98 72 65
98 72 60 50
Max Heap

Sample Input 2:

8
8 38 25 58 52 82 70 60

Sample Output 2:

8 25 70
8 25 82
8 38 52
8 38 58 60
Min Heap

Sample Input 3:

8
10 28 15 12 34 9 8 56

Sample Output 3:

10 15 8
10 15 9
10 28 34
10 28 12 56
Not Heap

我的思路: 28分

1. 不管怎样,堆顶要么是最大值,要么是最小值,根据此进行判断是max heap,min heap,还是 not heap

2. dfs深搜,打印路径,通过push和pop进行维护,先右子树,再左子树

3. 不知道在哪里有点逻辑错误,有一个不过

4. 又看了看代码,觉得能出问题应该就在大根堆小根堆不是堆这个地方了,可能逻辑判断有点问题,看了看柳神的代码,进行修改!

#include <cstdio>
#include <vector>
#include <algorithm>
using namespace std;

int n;
vector<int> heap, orderHeap, path;
int flag = 0; // 0: not heap, 1: min_heap, 2: max_heap

void dfs(int index){
	if(index <= n)path.push_back(heap[index]);
	else return;
	if(index*2 > n) {
		for(int i = 0; i < path.size(); i++)
			printf("%d%c", path[i], i != path.size()-1? ' ':'\n');
		path.pop_back();
		return;
	}
	dfs(index*2+1);
	dfs(index*2);
	path.pop_back();
}

int main() {
	scanf("%d", &n);
	heap.resize(n+1);
	for(int i = 1; i <= n; i++){
		scanf("%d", &heap[i]);
	}
	orderHeap = heap;
	sort(orderHeap.begin(), orderHeap.end());
	if(heap[1] == orderHeap[1]) flag = 1;
	if(heap[1] == orderHeap[n]) flag = 2;
	dfs(1);
	if(flag == 0){
		printf("Not Heap\n");
	}else if(flag == 1) printf("Min Heap\n");
	else if(flag == 2) printf("Max Heap\n");
	return 0;
}

30分: 

判断是否为堆:从第二个节点开始遍历,如果比父节点小,就不是小顶堆,如果比父节点大,就不是大顶堆

#include <cstdio>
#include <vector>
#include <algorithm>
using namespace std;

int n;
vector<int> heap, orderHeap, path;
int isMin = 1, isMax = 1;

void dfs(int index){
	if(index <= n)path.push_back(heap[index]);
	else return;
	if(index*2 > n && index*2+1 > n) { //没有孩子结点
		for(int i = 0; i < path.size(); i++)
			printf("%d%c", path[i], i != path.size()-1? ' ':'\n');
		path.pop_back();
		return;
	}
	dfs(index*2+1);
	dfs(index*2);
	path.pop_back();
}

int main() {
	scanf("%d", &n);
	heap.resize(n+1);
	for(int i = 1; i <= n; i++){
		scanf("%d", &heap[i]);
	}
	for (int i = 2; i <= n; i++) {
		if (heap[i/2] > heap[i]) isMin = 0;
		if (heap[i/2] < heap[i]) isMax = 0;
	}
	dfs(1);
	if (isMin == 1)
		printf("Min Heap");
	else 
		printf("%s", isMax == 1 ? "Max Heap" : "Not Heap"); 
	return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值