Sorting It All Out

Description

An ascending sorted sequence of distinct values is one in which some form of a less-than operator is used to order the elements from smallest to largest. For example, the sorted sequence A, B, C, D implies that A < B, B < C and C < D. in this problem, we will give you a set of relations of the form A < B and ask you to determine whether a sorted order has been specified or not.

Input

Input consists of multiple problem instances. Each instance starts with a line containing two positive integers n and m. the first value indicated the number of objects to sort, where 2 <= n <= 26. The objects to be sorted will be the first n characters of the uppercase alphabet. The second value m indicates the number of relations of the form A < B which will be given in this problem instance. Next will be m lines, each containing one such relation consisting of three characters: an uppercase letter, the character "<" and a second uppercase letter. No letter will be outside the range of the first n letters of the alphabet. Values of n = m = 0 indicate end of input.

Output

For each problem instance, output consists of one line. This line should be one of the following three: 

Sorted sequence determined after xxx relations: yyy...y. 
Sorted sequence cannot be determined. 
Inconsistency found after xxx relations. 

where xxx is the number of relations processed at the time either a sorted sequence is determined or an inconsistency is found, whichever comes first, and yyy...y is the sorted, ascending sequence. 

Sample Input

4 6
A<B
A<C
B<C
C<D
B<D
A<B
3 2
A<B
B<A
26 1
A<Z
0 0

Sample Output

Sorted sequence determined after 4 relations: ABCD.
Inconsistency found after 2 relations.
Sorted sequence cannot be determined.

#include <iostream>
#include <algorithm>
#include <string>
#include <string.h>
#include <set>
#include <queue>
const int maxn=30;
using namespace std;
char ww[26];
int a[26];
int n;
int ip;
int head[maxn],indegree[maxn],seq[maxn];

struct note
{
    int v,next;
} edge[maxn*maxn];
 
void init()
{
    memset(head,-1,sizeof(head));
    //memset(seq,'\0',sizeof(seq));
    ip=0;
}
 
void addedge(int u,int v)
{
    edge[ip].v=v,edge[ip].next=head[u],head[u]=ip++;
}
 
int topo()///拓扑,可做模板
{
    queue<int>q;
    int indeg[maxn];
    for(int i=0; i<n; i++)
    {	
        indeg[i]=indegree[i];
        if(indeg[i]==0)
            q.push(i);
    }
    int k=0;
    int res=0;
    int v;
    while(!q.empty())
    {
        if(q.size()!=1) {
        	res=1;
		}
        int u=q.front();
        q.pop();
        seq[k++]=u;
        for(int i=head[u]; i!=-1; i=edge[i].next)
        {	
            v=edge[i].v;
            indeg[v]--;
            if(indeg[v]==0)
                q.push(v);
        }
    }
    
	int sum=0;
	for(int i=0;i<26;i++)
		if(a[i])
			sum++;
			
    if(k<sum)return -1;///存在有向环,总之不能进行拓扑排序
    if(res)return 0;///可以进行拓扑排序,并且只有唯一一种方式,seq数组即是排序完好的序列
    return 1;///可以进行拓扑排序,有多种情况,seq数组是其中一种序列
}

int main(){
	int m;
	while(scanf("%d %d",&n,&m)!=EOF){
		char c1,c2,c3;
		if (!n && !m) 
			break;
		memset(a,0,sizeof(a));
		init();
		memset(indegree,0,sizeof(indegree));
		int err = -1,ans = -1;
		for(int i=0;i<m;i++){
			getchar();
			scanf("%c%c%c",&c1,&c3,&c2);
			if (err != -1 || ans != -1) continue;
			a[c1-'A']=1;
			a[c2-'A']=1;
			indegree[c2-'A']++;
			addedge(c1-'A',c2-'A');
			int res = topo();
			if (res == 1) ans = i + 1;
			else if (res == -1) err = i + 1;
		}
		if (ans != -1)
		{
			printf("Sorted sequence determined after %d relations: ", ans);
			for (int i = 0; i < n; ++i) putchar('A' + seq[i]);
			printf(".\n");
		}
		else if (err != -1)
		{
			printf("Inconsistency found after %d relations.\n", err);
		}
		else
		{
			printf("Sorted sequence cannot be determined.\n");
		}
	}
} 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值