Sorting It All Out(拓扑排序)

An ascending sorted sequence of distinct values is one in which some form of a less-than operator is used to order the elements from smallest to largest. For example, the sorted sequence A, B, C, D implies that A < B, B < C and C < D. in this problem, we will give you a set of relations of the form A < B and ask you to determine whether a sorted order has been specified or not.

Input

Input consists of multiple problem instances. Each instance starts with a line containing two positive integers n and m. the first value indicated the number of objects to sort, where 2 <= n <= 26. The objects to be sorted will be the first n characters of the uppercase alphabet. The second value m indicates the number of relations of the form A < B which will be given in this problem instance. Next will be m lines, each containing one such relation consisting of three characters: an uppercase letter, the character “<” and a second uppercase letter. No letter will be outside the range of the first n letters of the alphabet. Values of n = m = 0 indicate end of input.

Output

For each problem instance, output consists of one line. This line should be one of the following three:

Sorted sequence determined after xxx relations: yyy…y.
Sorted sequence cannot be determined.
Inconsistency found after xxx relations.

where xxx is the number of relations processed at the time either a sorted sequence is determined or an inconsistency is found, whichever comes first, and yyy…y is the sorted, ascending sequence.

Sample Input

4 6
A<B
A<C
B<C
C<D
B<D
A<B
3 2
A<B
B<A
26 1
A<Z
0 0

Sample Output

Sorted sequence determined after 4 relations: ABCD.
Inconsistency found after 2 relations.
Sorted sequence cannot be determined.

思路
对每一次操作,对该次操作进行一次拓扑排序,若此时存在多个入度为0的点,则可认为其为闭环,若只有一个入度为0的点,则此时该队列已成立,输出答案,以上两种情况成立时,结束操作,继续输入,若输入结束后操作未结束,则该队列无法成立

代码实现

#pragma GCC optimize(3,"Ofast","inline")
#include <bits/stdc++.h>

using namespace std;
typedef long long ll;
typedef pair<int,int> P;
const int N=30;

int n,m;
queue<int>que;
int mp[N][N],temp[N];
char s[N];
int ideg[N];
bool finsh;

void judge(int x)
{
    int pos=0;
    bool flag=true;
    while(!que.empty()) que.pop();
    for(int i=0;i<n;i++) temp[i]=ideg[i];
    for(int i=0;i<n;i++)
    {
        int cnt=0;
        for(int j=0;j<n;j++)
        {
            if(!temp[j])
            {
                cnt++;
                pos=j;
            }
        }
        if(!cnt)
        {
            finsh=true;
            printf("Inconsistency found after %d relations.\n",x);
            return ;
        }
        else
        {
            if(cnt>1) flag=false;
            for(int j=0;j<n;j++) if(mp[pos][j]) temp[j]--;
            temp[pos]--;
            que.push(pos);
        }
    }
    if(flag)
    {
        printf("Sorted sequence determined after %d relations: ",x);
        while(!que.empty())
        {
            printf("%c",que.front()+'A');
            que.pop();
        }
        puts(".");
        finsh=true;
    }
}
int main()
{
    while(~scanf("%d%d",&n,&m))
    {
        if(!n&&!m) break;
        memset(ideg,0,sizeof(ideg));
        memset(mp,0,sizeof(mp));
        finsh=false;
        for(int i=1;i<=m;i++)
        {
            scanf("%s",s);
            if(finsh) continue;
            int u=s[0]-'A',v=s[2]-'A';
            mp[u][v]=1;
            ideg[v]++;
            judge(i);
        }
        if(!finsh) puts("Sorted sequence cannot be determined.");
    }
    return 0;
}

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
Python拓扑排序可以通过使用深度优先搜索(DFS)算法来实现。有两种常见的实现方法。 第一种方法是使用递归的方式实现。在这种方法中,我们定义一个递归函数`topoSortvisit0`,它接受三个参数:当前节点`s`,访问状态列表`visited`和排序列表`sortlist`。首先,将当前节点标记为已访问。然后,对于当前节点的每个邻接节点,在邻接节点未被访问的情况下,递归调用`topoSortvisit0`函数。最后,将当前节点插入到排序列表的开头。接着,我们定义`topoSortDfs0`函数,初始化节点的访问状态列表`visited`和排序列表`sortlist`,然后对于图中的每个节点,如果节点未被访问,就调用`topoSortvisit0`函数。最后,返回排序列表即可得到拓扑排序的结果。 第二种方法是使用堆栈来实现。在这种方法中,我们定义一个辅助函数`topologicalSortUtil`,它接受三个参数:当前节点`v`,访问状态列表`visited`和堆栈`stack`。首先,将当前节点标记为已访问。然后,对于当前节点的每个邻接节点,如果邻接节点未被访问,就递归调用`topologicalSortUtil`函数。最后,将当前节点插入到堆栈的开头。接着,我们定义`topologicalSort`函数,初始化节点的访问状态列表`visited`和堆栈`stack`,然后对于图中的每个节点,如果节点未被访问,就调用`topologicalSortUtil`函数。最后,输出堆栈的内容即可得到拓扑排序的结果。 综上所述,可以使用上述两种方法之一来实现Python拓扑排序。<span class="em">1</span><span class="em">2</span><span class="em">3</span> #### 引用[.reference_title] - *1* *2* [拓扑排序(topological sorting)介绍及Python实现](https://blog.csdn.net/chenxy_bwave/article/details/125074013)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v93^chatsearchT3_2"}}] [.reference_item style="max-width: 50%"] - *3* [拓扑排序Python实现](https://blog.csdn.net/JohnJim0/article/details/121047511)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v93^chatsearchT3_2"}}] [.reference_item style="max-width: 50%"] [ .reference_list ]
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值