HDU1078 FatMouse and Cheese 记忆化搜索

6 篇文章 0 订阅

FatMouse and Cheese

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 16459 Accepted Submission(s): 7010

Problem Description
FatMouse has stored some cheese in a city. The city can be considered as a square grid of dimension n: each grid location is labelled (p,q) where 0 <= p < n and 0 <= q < n. At each grid location Fatmouse has hid between 0 and 100 blocks of cheese in a hole. Now he’s going to enjoy his favorite food.

FatMouse begins by standing at location (0,0). He eats up the cheese where he stands and then runs either horizontally or vertically to another location. The problem is that there is a super Cat named Top Killer sitting near his hole, so each time he can run at most k locations to get into the hole before being caught by Top Killer. What is worse – after eating up the cheese at one location, FatMouse gets fatter. So in order to gain enough energy for his next run, he has to run to a location which have more blocks of cheese than those that were at the current hole.

Given n, k, and the number of blocks of cheese at each grid location, compute the maximum amount of cheese FatMouse can eat before being unable to move.

Input
There are several test cases. Each test case consists of

a line containing two integers between 1 and 100: n and k
n lines, each with n numbers: the first line contains the number of blocks of cheese at locations (0,0) (0,1) … (0,n-1); the next line contains the number of blocks of cheese at locations (1,0), (1,1), … (1,n-1), and so on.
The input ends with a pair of -1’s.

Output
For each test case output in a line the single integer giving the number of blocks of cheese collected.

Sample Input
3 1
1 2 5
10 11 6
12 12 7
-1 -1

Sample Output
37

问题连接

问题描述

有只老鼠在城市里的洞里藏了奶酪,城市可以看成是n*n个小方格组成的大方格,每个小方格里有一些奶酪,现在有一只猫在追它,老鼠必须跑到洞里,才能躲暂时避猫的追捕,并且会把洞里的奶酪吃完。但是,老鼠为了保持能量需要到其它洞里吃奶酪,而且每次吃奶酪,老鼠都会变胖,为了躲避猫的追捕,必须吃更多的奶酪,否则能量不够会被猫抓到。老鼠每次行动都只能时沿着一个方向跑,最多能跑K个小方格长的距离。问老鼠从(0,0)出发,最多能吃到多少个奶酪。

问题分析

记忆化搜索。利用dfs一步步往下搜,当无法更深地搜索时回溯,用dp记录搜索到的点能得到的奶酪量的最大值(逆向进行)。这个最大值是来自在当前点向4个方向不同单位长度移动到达的点的返回值。
逆向进行的时候,每个点的最优解是dfs中更深的点的最优解中的最大值与当前点的奶酪数的和。
如果访问过,那么这一点处就有它的最优的解,所以直接回溯,从而减少重复的运算。
如果超出边界,这是老鼠无法进行的,那么返回奶酪数为0。
如此操作,dfs回溯到(0,0)时,就能得到(0,0)处的最优解。

程序如下

#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstring>
using namespace std;
const int N=105;
int n,k;

int dir[4][2]={{0,1},{1,0},{0,-1},{-1,0}};
int dp[N][N];
int grid[N][N];
bool vis[N][N];

int dfs(int x,int y){
	if(x<0||y<0||x>=n||y>=n) return 0;//越界返回 
	if(vis[x][y]) return dp[x][y];//如果访问过就返回该处的最优解,以减少重复运算 
	
	vis[x][y]=1;//访问标记 
	
	int i,j,X,Y,ret;
	ret=0;
	for(i=0;i<4;i++){
		for(j=1;j<=k;j++){
		X=dir[i][0]*j+x;
		Y=dir[i][1]*j+y;
		if(X<0||Y<0||X>=n||Y>=n) continue;//防止数组越界
		if(grid[X][Y]> grid[x][y]) ret=max(ret,dfs(X,Y));//找到最好的方案
		//如果下一区域的奶酪数比当前区域的奶酪数多就访问 
		}
	}
	return dp[x][y]=ret+grid[x][y];//最优解+当前区域奶酪数 
}
int main(){
	int i,j,ans;
	while(scanf("%d %d",&n,&k)!=EOF){
		if(n==-1&&k==-1) break;
		for(i=0;i<n;i++){
			for(j=0;j<n;j++)
			scanf("%d",&grid[i][j]);
		}
		memset(vis,0,sizeof(vis));
		memset(dp,0,sizeof(dp));
		dfs(0,0);
		printf("%d\n",dp[0][0]);
	}
	return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值