BUY LOW, BUY LOWER----POJ_1952----最长递减子序列

题目地址:http://poj.org/problem?id=1952

BUY LOW, BUY LOWER
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 6692 Accepted: 2302

Description

The advice to "buy low" is half the formula to success in the bovine stock market.To be considered a great investor you must also follow this problems' advice: 
                    "Buy low; buy lower"

Each time you buy a stock, you must purchase it at a lower price than the previous time you bought it. The more times you buy at a lower price than before, the better! Your goal is to see how many times you can continue purchasing at ever lower prices. 

You will be given the daily selling prices of a stock (positive 16-bit integers) over a period of time. You can choose to buy stock on any of the days. Each time you choose to buy, the price must be strictly lower than the previous time you bought stock. Write a program which identifies which days you should buy stock in order to maximize the number of times you buy. 

Here is a list of stock prices: 
 Day   1  2  3  4  5  6  7  8  9 10 11 12

Price 68 69 54 64 68 64 70 67 78 62 98 87


The best investor (by this problem, anyway) can buy at most four times if each purchase is lower then the previous purchase. One four day sequence (there might be others) of acceptable buys is: 
Day    2  5  6 10

Price 69 68 64 62

Input

* Line 1: N (1 <= N <= 5000), the number of days for which stock prices are given 

* Lines 2..etc: A series of N space-separated integers, ten per line except the final line which might have fewer integers. 

Output

Two integers on a single line: 
* The length of the longest sequence of decreasing prices 
* The number of sequences that have this length (guaranteed to fit in 31 bits) 

In counting the number of solutions, two potential solutions are considered the same (and would only count as one solution) if they repeat the same string of decreasing prices, that is, if they "look the same" when the successive prices are compared. Thus, two different sequence of "buy" days could produce the same string of decreasing prices and be counted as only a single solution. 

Sample Input

12
68 69 54 64 68 64 70 67 78 62
98 87

Sample Output

4 2

Source



此题的题意就是,在买股票的时候你这次买的股票的价格必须严格小于你上一次买的股票。如果你买的次数越多就越好。现在给你若干股票。每天一支。有n天。让你求出在这个顺序下最多能买多少只股票。除此之外,还要你给出买最长的股票下不同的方案有多少种。如果两种方案中下降的序列是一样的话就只能算作一种。现在要给出最长的长度,以及最长长度的不同方案数。用f[i]表示在以第i个结尾的最长递减子序列的长度,用count[i]表示以第i个结尾时f[i]长度的不同方案数。用data[i]保存每个的价值。
则状态转移方程为:
      f[i] = max(f[j]+1)     0<=j<i   && data[j] > data[i]
      count[i] = sum(count[j])  0<=j<i && f[i] = f[j]+1 && data[j]>data[i]
需要指出的是
如果f[i] == f[j]  && data[i] == data[j]    则他们在下降子序列的位置是一样的而且值也一样,只需要计算它们中的第一个就可以了,其余的不必计算在内。而且这个事求递减的子序列,则我们需将data[0]置为一个很大的数,这其它的数相对于它都是递减的。

#include<iostream>
using namespace std;

#define MAX 5050

long f[MAX]; //f[i]表示以第i个元素作为最后一个字符的最长递减子序列的长度 
long data[MAX];
long count[MAX];//表示以第i个元素作为最后一个字符且长度为f[i]的是不同的最长递减子序列的方案数 

int main()
{
	int n;
	while(cin>>n && n)
	{
		int i,j;
		int max = 0;

		for(i=1;i<=n;i++)
		{
			cin>>data[i];
			//赋初值,因为一开始的时候什么都还没有,所以赋0 
			f[i] = 0;
			count[i] = 0;
		}
		f[0] = 0;

		//求最大递减子序列
		data[0] = 999999999;
		for(i=1;i<=n;i++)
		{
			for(j=i-1;j>=0;j--)
				if(data[j] > data[i] && f[j] + 1 > f[i])
					f[i] = f[j] + 1;

			if(max < f[i])//将最长的长度保存 
				max = f[i];
		}
		//


		//计算数量,也是一个DP,转换方程为
		//count[i] = all(count[j])  && dp[i] = dp[j]+1 && data[i]<data[j]
		//还要注意去除掉序列中相同位置且数据相同的元素,我采用的是去除的方法
		int Acount = 0;
		count[0] = 1;

		for(i=1;i<=n;i++)
		{
			for(j=i-1;j>=0;j--)
			{
				if(f[i] == f[j] && data[i] == data[j]) //位置和数据一致,则不重复计算
					break;
				if(f[i] == f[j]+1 && data[i] < data[j])
					count[i]+=count[j];
			}
			if(f[i] == max  && count[i])  //达到了最长子序列的长度 
				Acount += count[i];
			//cout<<"----------------"<<endl;
			//cout<<i<<" "<<count[i]<<endl;
		}

		cout<<max<<" "<<Acount<<endl;
	}

	return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值