acm ural [1066] Garland solution report

original problem: http://acm.timus.ru/problem.aspx?space=1&num=1066

content:

Garland
Time Limit: 2.0 second
Memory Limit: 16 MB

 

Sample garland picture The New Year garland consists of N lamps attached to a common wire that hangs down on the ends to which outermost lamps are affixed. The wire sags under the weight of lamp in a particular way: each lamp is hanging at the height that is 1 millimeter lower than the average height of the two adjacent lamps.

The leftmost lamp in hanging at the height of A millimeters above the ground. You have to determine the lowest height B of the rightmost lamp so that no lamp in the garland lies on the ground though some of them may touch the ground.

You shall neglect the lamp's size in this problem. By numbering the lamps with integers from 1 to N and denoting the ith lamp height in millimeters as Hi we derive the following equations:

  • H1 = A
  • Hi = (Hi-1 + Hi+1)/2 - 1, for all 1 < i < N
  • HN = B
  • Hi ≥ 0, for all 1 ≤ iN

The sample garland with 8 lamps that is shown on the picture has A = 15 and B = 9.75.

 

Input

 

The input consists of a single line with two numbers N and A separated by a space. N (3 ≤ N ≤ 1000) is an integer representing the number of lamps in the garland, A (10 ≤ A ≤ 1000) is a real number representing the height of the leftmost lamp above the ground in millimeters.

 

Output

 

Write to the output the single real number B accurate to two digits to the right of the decimal point representing the lowest possible height of the rightmost lamp.

 

Sample Input

692 532.81

Sample Output

446113.34
 
my report:
Note that there’re totally N points respectively (H1,H2,…,HN)
   
   
And through the given equation Hi=(Hi-1+Hi+1)/2-1
   
   
We can derive the third number by the former 2.
   
   
That means we ought to just assume a H2, using half-dividing method.
Here we know that if any number of the sequence appears below zero at the given H2, 
it shall be adjusted to another value, if c(let’s define it as the every number actually it is) 
is less than zero,
we should increase H2, vice versa. We call it enumerate.
code in JAVA:
import java.io.*;
import java.util.*;

 

public class Application
{
    public static void main(String[] args) throws IOException
    {
        new Application().run();
    }

 

    StreamTokenizer in;
    PrintWriter out;

 

    int nextInt() throws IOException
    {
        in.nextToken();
        return (int) in.nval;
    }

 

    double nextDouble() throws IOException
    {
        in.nextToken();
        return (double) in.nval;
    }

 

    void run() throws IOException
    {
        in = new StreamTokenizer(new BufferedReader(new InputStreamReader(
            System.in)));
        out = new PrintWriter(new OutputStreamWriter(System.out));
        solve();
        out.flush();
    }

 

    void solve() throws IOException
    {

 

        double a, b, c, l, r, h1, h2;

        int n = nextInt();
        h1 = nextDouble();

 

        l = 0;
        r = h1;

 

        while (true)
        {
            b = h1;
            h2 = (l + r) / 2;
            c = h2;

 

            for (int i = 3; i <= n; i++)
            {
                a = b;
                b = c;
                c = 2 * (b + 1) - a;
                if (c < 0)
                {
                    break;
                }
            }

 

            if (c < 0)
            {
                l = h2;
            }
            else
            {
                r = h2;
            }

 

            if (r - l < 1E-10 && c >= 0)
            {
                break;
            }
        }

 

        out.println(round(c));
    }

 

    double round(double d)
    {
       int i=(int)(d*100+0.5);
       double k=(double)(i/100.00);
       return k;
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
智慧校园的建设目标是通过数据整合、全面共享,实现校园内教学、科研、管理、服务流程的数字化、信息化、智能化和多媒体化,以提高资源利用率和管理效率,确保校园安全。 智慧校园的建设思路包括构建统一支撑平台、建立完善管理体系、大数据辅助决策和建设校园智慧环境。通过云架构的数据中心与智慧的学习、办公环境,实现日常教学活动、资源建设情况、学业水平情况的全面统计和分析,为决策提供辅助。此外,智慧校园还涵盖了多媒体教学、智慧录播、电子图书馆、VR教室等多种教学模式,以及校园网络、智慧班牌、校园广播等教务管理功能,旨在提升教学品质和管理水平。 智慧校园的详细方案设计进一步细化了教学、教务、安防和运维等多个方面的应用。例如,在智慧教学领域,通过多媒体教学、智慧录播、电子图书馆等技术,实现教学资源的共享和教学模式的创新。在智慧教务方面,校园网络、考场监控、智慧班牌等系统为校园管理提供了便捷和高效。智慧安防系统包括视频监控、一键报警、阳光厨房等,确保校园安全。智慧运维则通过综合管理平台、设备管理、能效管理和资产管理,实现校园设施的智能化管理。 智慧校园的优势和价值体现在个性化互动的智慧教学、协同高效的校园管理、无处不在的校园学习、全面感知的校园环境和轻松便捷的校园生活等方面。通过智慧校园的建设,可以促进教育资源的均衡化,提高教育质量和管理效率,同时保障校园安全和提升师生的学习体验。 总之,智慧校园解决方案通过整合现代信息技术,如云计算、大数据、物联网和人工智能,为教育行业带来了革命性的变革。它不仅提高了教育的质量和效率,还为师生创造了一个更加安全、便捷和富有智慧的学习与生活环境。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

dracularking

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值