HDU3038 How Many Answers Are Wrong 带权并查集

1.题目描述:

How Many Answers Are Wrong

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 6989    Accepted Submission(s): 2587


Problem Description
TT and FF are ... friends. Uh... very very good friends -________-b

FF is a bad boy, he is always wooing TT to play the following game with him. This is a very humdrum game. To begin with, TT should write down a sequence of integers-_-!!(bored).

Then, FF can choose a continuous subsequence from it(for example the subsequence from the third to the fifth integer inclusively). After that, FF will ask TT what the sum of the subsequence he chose is. The next, TT will answer FF's question. Then, FF can redo this process. In the end, FF must work out the entire sequence of integers.

Boring~~Boring~~a very very boring game!!! TT doesn't want to play with FF at all. To punish FF, she often tells FF the wrong answers on purpose.

The bad boy is not a fool man. FF detects some answers are incompatible. Of course, these contradictions make it difficult to calculate the sequence.

However, TT is a nice and lovely girl. She doesn't have the heart to be hard on FF. To save time, she guarantees that the answers are all right if there is no logical mistakes indeed.

What's more, if FF finds an answer to be wrong, he will ignore it when judging next answers.

But there will be so many questions that poor FF can't make sure whether the current answer is right or wrong in a moment. So he decides to write a program to help him with this matter. The program will receive a series of questions from FF together with the answers FF has received from TT. The aim of this program is to find how many answers are wrong. Only by ignoring the wrong answers can FF work out the entire sequence of integers. Poor FF has no time to do this job. And now he is asking for your help~(Why asking trouble for himself~~Bad boy)
 

Input
Line 1: Two integers, N and M (1 <= N <= 200000, 1 <= M <= 40000). Means TT wrote N integers and FF asked her M questions.

Line 2..M+1: Line i+1 contains three integer: Ai, Bi and Si. Means TT answered FF that the sum from Ai to Bi is Si. It's guaranteed that 0 < Ai <= Bi <= N.

You can assume that any sum of subsequence is fit in 32-bit integer.
 

Output
A single line with a integer denotes how many answers are wrong.
 

Sample Input
  
  
10 5 1 10 100 7 10 28 1 3 32 4 6 41 6 6 1
 

Sample Output
  
  
1
 

Source
 

Recommend
gaojie   |   We have carefully selected several similar problems for you:   3033  3035  3036  3037  3031 
 

2.题意概述:

有n次询问,给出a到b区间的总和,问这n次给出的总和中有几次是和前面已近给出的是矛盾的?

3.解题思路:

线段树??no!!带权并查集。我们对给出的区间a,b做以下操作,a-1,b   这样的话,当区间为1--2   3--4的时候,我们可以把两个区间合并成是区间1----4。在更新的时候,数值小的一定是为根节点,如此我们围绕根节点来更新就可。具体实现呢:

用带权并查集做, 对于并查集中的每一棵数, 树根的距离为0,然后以树根作为参照,每个结点的权值代表与树根的距离。
合并A,B时,假设A,B属于不同的树,那么就要合并这两棵树, 把A树合并到B树上,这时要给A树的跟结点root_a赋值,关键是给root_a附上一个什么值。 由于A点和B点的权值rank[A]和rank[B]都是相对跟结点的距离,所以分析A,B之间的相对距离,可以得到rank[root_a] = rank[A]+x-rank[B]。 注意到这时,对于原来的A的树,只跟新了root_a跟结点的权值, 那么其它结点的跟新在查找的那一步里面实行了。

4.AC代码:

#include <stdio.h>
#include <cmath>
#define maxn 200200
using namespace std;
int pa[maxn], rank[maxn];
void init(int n)
{
	for (int i = 0; i <= n; i++)
	{
		pa[i] = i;
		rank[i] = 0;
	}
}
int findset(int x)
{
	if (x == pa[x])
		return x;
	int temp = pa[x];
	pa[x] = findset(temp);
	rank[x] += rank[temp];
	return pa[x];
}
int unionset(int a, int b, int s)
{
	int a1 = findset(a);
	int b1 = findset(b);
	if (a1 == b1)
	{
		if (abs(rank[a] - rank[b]) != s)
			return 0;
	}
	else
	{
		pa[a1] = b1;
		rank[a1] = rank[b] + s - rank[a];
	}
	return 1;
}
int main()
{
	int n, m;
	while (scanf("%d%d", &n, &m) != EOF)
	{
		int ans = 0;
		init(n);
		for (int i = 0; i < m; i++)
		{
			int a, b, s;
			scanf("%d%d%d", &a, &b, &s);
			a--;
			if (!unionset(a, b, s))
				ans++;
		}
		printf("%d\n", ans);
	}
    return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值