HDU2289 - Cup - 二分

1.题目描述:

Cup

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 8400    Accepted Submission(s): 2566


Problem Description
The WHU ACM Team has a big cup, with which every member drinks water. Now, we know the volume of the water in the cup, can you tell us it height? 

The radius of the cup's top and bottom circle is known, the cup's height is also known.
 

Input
The input consists of several test cases. The first line of input contains an integer T, indicating the num of test cases.
Each test case is on a single line, and it consists of four floating point numbers: r, R, H, V, representing the bottom radius, the top radius, the height and the volume of the hot water.

Technical Specification

1. T ≤ 20.
2. 1 ≤ r, R, H ≤ 100; 0 ≤ V ≤ 1000,000,000.
3. r ≤ R.
4. r, R, H, V are separated by ONE whitespace.
5. There is NO empty line between two neighboring cases.

 

Output
For each test case, output the height of hot water on a single line. Please round it to six fractional digits.
 

Sample Input
  
  
1 100 100 100 3141562
 

Sample Output
  
  
99.999024
 

Source
 

Recommend
lcy
 
2.题意概述:

• 已知一只杯子的上下底半径R和r,以及高度H
• 向杯子中倒入体积为V的水
• 求杯子中水的高度h
• 其中1 <= r, R, H <= 100,r <= R
• 最终结果保留6位小数

3.解题思路:


4.AC代码:

#include <cstdio>
#include <iostream>
#include <cstring>
#include <string>
#include <algorithm>
#include <cmath>
#include <vector>
#include <queue>
#include <map>
#include <set>
#include <ctime>
using namespace std;
typedef long long ll;
#define INF 0x3f3f3f3f
#define maxn 1111
#define eps 1e-10
#define pi acos(-1.0)
double r, R, H, V;
double judge(double h)
{
	double r1 = h / H * (R - r) + r;
	return pi * h * (r * r + r * r1 + r1 * r1) / 3;
}
int main()
{
	/*
	#ifdef ONLINE_JUDGE
	freopen("in.txt","r",stdin);
	freopen("out.txt","w",stdout);
	#endif
	*/
	int t;
	scanf("%d", &t);
	while (t--)
	{
		scanf("%lf%lf%lf%lf", &r, &R, &H, &V);
		if (judge(H) <= V)
		{
			printf("%.6lf\n", H);
			continue;
		}
		double l = 0, r = H, m;
		while (r - l > eps)
		{
			m = l + (r - l) / 2;
			if (judge(m) > V)
				r = m;
			else
				l = m;
		}
		printf("%.6lf\n", m);
	}
	return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值