POJ3259 - Wormholes - 最短路判负环

1.题目描述:

Wormholes
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 49130 Accepted: 18114

Description

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..NM (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input

Line 1: A single integer,  FF farm descriptions follow. 
Line 1 of each farm: Three space-separated integers respectively:  NM, and  W 
Lines 2.. M+1 of each farm: Three space-separated numbers ( SET) that describe, respectively: a bidirectional path between  S and  E that requires  T seconds to traverse. Two fields might be connected by more than one path. 
Lines  M+2.. M+ W+1 of each farm: Three space-separated numbers ( SET) that describe, respectively: A one way path from  S to  E that also moves the traveler back  T seconds.

Output

Lines 1.. F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).

Sample Input

2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8

Sample Output

NO
YES

Hint

For farm 1, FJ cannot travel back in time. 
For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.

Source

2.题意概述:

农夫约翰在探索他的许多农场,发现了一些惊人的虫洞。虫洞是很奇特的,因为它是一个单向通道,可让你进入虫洞的前达到目的地!他的N(1≤N≤500)个农场被编号为1..N,之间有M(1≤M≤2500)条路径,W(1≤W≤200)个虫洞。FJ作为一个狂热的时间旅行的爱好者,他要做到以下几点:开始在一个区域,通过一些路径和虫洞旅行,他要回到最开时出发的那个区域出发前的时间。也许他就能遇到自己了:)。为了帮助FJ找出这是否是可以或不可以,他会为你提供F个农场的完整的映射到(1≤F≤5)。所有的路径所花时间都不大于10000秒,所有的虫洞都不大于万秒的时间回溯。

输入

第1行:一个整数F表示接下来会有F个农场说明。

每个农场第一行:分别是三个空格隔开的整数:N,M和W

第2行到M+1行:三个空格分开的数字(S,E,T)描述,分别为:需要T秒走过S和E之间的双向路径。两个区域可能由一个以上的路径来连接。

第M +2到M+ W+1行:三个空格分开的数字(S,E,T)描述虫洞,描述单向路径,S到E且回溯T秒。

输出

F行,每行代表一个农场

每个农场单独的一行,” YES”表示能满足要求,”NO”表示不能满足要求。

3.解题思路:

能时间回溯,那么就说明有负环。这道题是判断负环的又一个经典问题。更正一下spfa判断负环的话如果用的是in[v] == n那必须保证每条路最多1条边,当时做这题一直wa最后 发现果然是自己知识掌握太死板,还有优化方案在这题针对的dis是起点,因为本身就有负权。这里我也用了deque优化确实快了不少!

4.AC代码:

#include <cstdio>
#include <iostream>
#include <cstring>
#include <string>
#include <algorithm>
#include <functional>
#include <cmath>
#include <vector>
#include <queue>
#include <deque>
#include <stack>
#include <map>
#include <set>
#include <ctime>
#define INF 0x3f3f3f3f
#define maxn 100100
#define N 511
#define eps 1e-6
#define pi acos(-1.0)
#define e exp(1.0)
using namespace std;
const int mod = 1e9 + 7;
typedef long long ll;
typedef unsigned long long ull;
int mp[N][N];
int dis[N], in[N];
bool vis[N];
bool spfa(int sta, int n)
{
	fill(dis, dis + n + 1, INF);
	memset(vis, 0, sizeof(vis));
	memset(in, 0, sizeof(in));
	deque<int> q;
	dis[sta] = 0;
	vis[sta] = 1;
	in[sta] = 1;
	q.push_back(sta);
	while (!q.empty())
	{
		int u = q.front();
		q.pop_front();
		vis[u] = 0;
		for (int i = 1; i <= n; i++)
		{
			int v = i;
			int val = mp[u][v];
			if (dis[v] > dis[u] + val)
			{
				dis[v] = dis[u] + val;
				if (!vis[v])
				{
					in[v]++;
					if (in[v] == n)
						return 1;
					vis[v] = 1;
					if (!q.empty() && dis[v] <= dis[q.front()])
						q.push_front(v);
					else
						q.push_back(v);
				}
			}
		}
		if (dis[sta] < 0)
			return 1;
	}
	return 0;
}
int main()
{
#ifndef ONLINE_JUDGE
	freopen("in.txt", "r", stdin);
	freopen("out.txt", "w", stdout);
	long _begin_time = clock();
#endif
	int t, n, m, w;
	scanf("%d", &t);
	while (t--)
	{
		scanf("%d%d%d", &n, &m, &w);
		for (int i = 1; i <= n; i++)
			for (int j = 1; j <= n; j++)
				mp[i][j] = INF;
		for (int i = 0; i < m; i++)
		{
			int u, v, d;
			scanf("%d%d%d", &u, &v, &d);
			mp[u][v] = mp[v][u] = min(mp[u][v], d);
		}
		for (int i = 0; i < w; i++)
		{
			int u, v, d;
			scanf("%d%d%d", &u, &v, &d);
			mp[u][v] = min(mp[u][v], -d);
		}
		if (spfa(1, n))
			puts("YES");
		else
			puts("NO");
	}
#ifndef ONLINE_JUDGE
	long _end_time = clock();
	printf("time = %ld ms.", _end_time - _begin_time);
#endif
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值