POJ3349 - Snowflake Snow Snowflakes - 哈希+暴力

1.题目描述:

Snowflake Snow Snowflakes
Time Limit: 4000MS Memory Limit: 65536K
Total Submissions: 41351 Accepted: 10897

Description

You may have heard that no two snowflakes are alike. Your task is to write a program to determine whether this is really true. Your program will read information about a collection of snowflakes, and search for a pair that may be identical. Each snowflake has six arms. For each snowflake, your program will be provided with a measurement of the length of each of the six arms. Any pair of snowflakes which have the same lengths of corresponding arms should be flagged by your program as possibly identical.

Input

The first line of input will contain a single integer n, 0 < n ≤ 100000, the number of snowflakes to follow. This will be followed by n lines, each describing a snowflake. Each snowflake will be described by a line containing six integers (each integer is at least 0 and less than 10000000), the lengths of the arms of the snow ake. The lengths of the arms will be given in order around the snowflake (either clockwise or counterclockwise), but they may begin with any of the six arms. For example, the same snowflake could be described as 1 2 3 4 5 6 or 4 3 2 1 6 5.

Output

If all of the snowflakes are distinct, your program should print the message:
No two snowflakes are alike.
If there is a pair of possibly identical snow akes, your program should print the message:
Twin snowflakes found.

Sample Input

2
1 2 3 4 5 6
4 3 2 1 6 5

Sample Output

Twin snowflakes found.

Source

2.题意概述:

给你n片雪花的6个角距离中心的距离,定义两片雪花相同当且仅当它们六个角到达中心轴的距离都相同,要你判断这n片雪花是否相同。

3.解题思路:

考虑对每片雪花的特征值进行哈希处理,但是为了保险,当哈希值相同时候可以考虑再暴力判断这两个雪花的6个值是否真相同。

4.AC代码:

#include <cstdio>
#include <iostream>
#include <cstring>
#include <string>
#include <algorithm>
#include <functional>
#include <cmath>
#include <vector>
#include <queue>
#include <map>
#include <set>
#include <ctime>
#define INF 0x7fffffff
#define maxn 100010
#define eps 1e-6
#define pi acos(-1.0)
#define e 2.718281828459
#define mod (int)1e9 + 7;
#define hsprime 99991
using namespace std;
typedef long long ll;
struct node
{
  int side[6];
} snow;
vector<node> hs[hsprime];
void hash(node x)
{
  int addx = 0;
  for (int i = 0; i < 6; i++)
    addx += x.side[i];
  addx %= hsprime;
  hs[addx].push_back(x);
}
bool cmp(node a, node b) //正反对比
{
  for (int i = 0; i < 6; i++)
  {
    if (a.side[0] == b.side[i] && a.side[1] == b.side[(i + 1) % 6] && a.side[2] == b.side[(i + 2) % 6] && a.side[3] == b.side[(i + 3) % 6] && a.side[4] == b.side[(i + 4) % 6] && a.side[5] == b.side[(i + 5) % 6])
      return true;
    if (a.side[0] == b.side[i] && a.side[1] == b.side[(i + 5) % 6] && a.side[2] == b.side[(i + 4) % 6] && a.side[3] == b.side[(i + 3) % 6] && a.side[4] == b.side[(i + 2) % 6] && a.side[5] == b.side[(i + 1) % 6])
      return true;
  }
  return false;
}
int main()
{
#ifndef ONLINE_JUDGE
  freopen("in.txt", "r", stdin);
  freopen("out.txt", "w", stdout);
  long _begin_time = clock();
#endif
  int n;
  while (scanf("%d", &n) != EOF)
  {
    for (int i = 0; i < hsprime; i++)
      hs[i].clear();
    for (int i = 0; i < n; i++)
    {
      for (int j = 0; j < 6; j++)
        scanf("%d", &snow.side[j]);
      hash(snow);
    }
    int flag = 0;
    for (int i = 0; i < hsprime; i++)
    {
      if (hs[i].size() > 1)
      {
        for (int j = 0; j < hs[i].size(); j++)
        {
          for (int k = j + 1; k < hs[i].size(); k++)
            if (cmp(hs[i][j], hs[i][k]))
            {
              flag = 1;
              break;
            }
        }
      }
    }
    if (flag)
      puts("Twin snowflakes found.");
    else
      puts("No two snowflakes are alike.");
  }
#ifndef ONLINE_JUDGE
  long _end_time = clock();
  printf("time = %ld ms\n", _end_time - _begin_time);
#endif
  return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值