glibc-commons 依赖解析 版本错误,xxx is duplicate yyy

glibc-commons 安装了两个版本,导致依赖glibc-commons的很多软件包 被安装了两个版本;

解决办法就是 先清除这些重复的已安装的软件,然后执行 yum update 将 glibc-commons 更新一下

1.清除重复的已安装的包

sudo package-cleanup --cleandupes

2.更新软件包

sudo yum update

3.安装 gcc

sudo yum install gcc

4.清理未完成的yum事务

sudo yum-complete-transaction --cleanup-only
sudo yum install gcc-c++

补充:

1.列出有问题的软件包

sudo package-cleanup --problems

2.列出 重复安装的软件包

sudo package-cleanup --dupes
©️2020 CSDN 皮肤主题: 大白 设计师: CSDN官方博客 返回首页
实付0元
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、C币套餐、付费专栏及课程。

余额充值