poj 2078 矩阵右移问题

 问题描述

                                               Matrix

Description

Given an n*n matrix A, whose entries Ai,j are integer numbers ( 0 <= i < n, 0 <= j < n ). An operation SHIFT at row i ( 0 <= i < n ) will move the integers in the row one position right, and the rightmost integer will wrap around to the leftmost column.


You can do the SHIFT operation at arbitrary row, and as many times as you like. Your task is to minimize

max0<=j< n{Cj|Cj=Σ0<=i< nAi,j}

 

Input

The input consists of several test cases. The first line of each test case contains an integer n.  Each of the following n lines contains n integers, indicating the matrix A. The input is terminated by a single line with an integer −1. You may assume that 1 <= n <= 7 and |Ai,j| < 104.

Output

For each test case, print a line containing the minimum value of the maximum of column sums.

Sample Input

2

4 6

3 7

3

1 2 3

4 5 6

7 8 9

-1

Sample Output

11

15

题目思路

输入一个方阵,可以对矩阵的每一行进行任意次的右移操作,求出位移后的矩阵每列的最大值,然后多次位移,得到多组最大值,最后求出这些最大值中的最小值。关键还是排列组合的问题,对于一个n*n的矩阵来说,第一行位移有n种形式,第二行也有n种,以此类推,故总的有n*n种矩阵的形态。可以利用dfs搜索出这些状态,固定当前的行,去递归调用剩余的行,进而计算出每种矩阵形态的值。由于矩阵的右移是相对的,所以可以直接从第二行直接搜索。节省时间。

代码

#include<stdio.h>
#include<stdlib.h>
#include<string.h>

int n,max,min,sum;
int num[10][10];//定义一个10x10的矩阵 

void move(int m)//第m行右移一次 
{
  int a,i;
  a=num[m][n];
  for(i=n-1;i>=1;i--){
    num[m][i+1]=num[m][i];
  }
  num[m][1]=a;
}

void dfs(int k)//k代表着即将要移动的行下标 
{
  int i,j;
  if(k==n+1)  {  //表示关键点处的for循环里面的move已经移动到完了最后一行,求此排列的每列的和,并且暂时得出最小值   
    max=0;
    for(i=1;i<=n;i++){
      sum=0;
      for(j=1;j<=n;j++){
        sum=sum+num[j][i];
      }
      if(sum>max){
        max=sum;
      }
    }
    if(max<min){
      min=max;
    }
    return;
  }
  for(i=1;i<=n;i++){  //关键点 
    move(k);//移动第k行 
    dfs(k+1);//然后以移动第k行为基础,遍历移动后面的行数, 
  }
}

int main()
{
  int i,j;
  while((scanf("%d",&n)!=EOF)&&(n!=-1)){
    for(i=1;i<=n;i++) {
      for(j=1;j<=n;j++){
        scanf("%d",&num[i][j]);
      }
    }
max=0;
min=0x7fffffff;// 
    dfs(2);//从第二行开始移动, 
    printf("%d\n",min);
  }
  return 0;
}

 

  • 0
    点赞
  • 3
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值