江苏省赛 JSCPC2018 F. Sorting

F. Sorting

Bobo has n tuples (a1,b1,c1),(a2,b2,c2),…,(an,bn,cn). He would like to find the lexicographically smallest permutation p1,p2,…,pn of 1,2,…,n such that for i ∈{2,3,…,n} it holds that
(a[p-1]+b[p-1])/(a[p-1]+b[p-1]+c[p-1]) <= (a[p]+b[p])/(a[p]+b[p]+c[p])

Input

The input consists of several test cases and is terminated by end-of-file. The first line of each test case contains an integer n. The i-th of the following n lines contains 3 integers ai, bi and ci.

Output

For each test case, print n integers p1,p2,…,pn seperated by spaces. DO NOT print trailing spaces.
Constraint • 1≤ n ≤10^3 • 1≤ ai,bi,ci ≤2×10^9 • The sum of n does not exceed 10^4.

Sample Input

2
1 1 1
1 1 2
2
1 1 2
1 1 1
3
1 3 1
2 2 1
3 1 1

Sample Output

2 1
1 2
1 2 3

题解
  • 将n个三元组排序,排序要求见题中公式
  • 贪心解决
代码

来自官方的solution

#include <algorithm>
#include <cstdio>

const int N = 100000;

int a[N], b[N], c[N], ord[N];

bool cmp(int i, int j)
{
    auto x = c[i] * (1ULL * a[j] + b[j] + c[j]);
    auto y = c[j] * (1ULL * a[i] + b[i] + c[i]);
    if (x == y) {
        return i < j;
    }
    return x > y;
}

int main()
{
    int n;
    while (scanf("%d", &n) == 1) {
        for (int i = 0; i < n; ++ i) {
            scanf("%d%d%d", a + i, b + i, c + i);
            ord[i] = i;
        }
        std::sort(ord, ord + n, cmp);
        for (int i = 0; i < n; ++ i) {
            printf("%d%c", ord[i] + 1, " \n"[i == n - 1]);
        }
    }
}

注:

个人拙见,如大家有发现错误,请留言指出,万分感谢!

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值