How far away ?

 How far away ?

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 19131    Accepted Submission(s): 7485


Problem Description
There are n houses in the village and some bidirectional roads connecting them. Every day peole always like to ask like this "How far is it if I want to go from house A to house B"? Usually it hard to answer. But luckily int this village the answer is always unique, since the roads are built in the way that there is a unique simple path("simple" means you can't visit a place twice) between every two houses. Yout task is to answer all these curious people.
 

Input
First line is a single integer T(T<=10), indicating the number of test cases.
  For each test case,in the first line there are two numbers n(2<=n<=40000) and m (1<=m<=200),the number of houses and the number of queries. The following n-1 lines each consisting three numbers i,j,k, separated bu a single space, meaning that there is a road connecting house i and house j,with length k(0<k<=40000).The houses are labeled from 1 to n.
  Next m lines each has distinct integers i and j, you areato answer the distance between house i and house j.
 

Output
For each test case,output m lines. Each line represents the answer of the query. Output a bland line after each test case.
 

Sample Input
  
  
2 3 2 1 2 10 3 1 15 1 2 2 3 2 2 1 2 100 1 2 2 1
 

Sample Output
  
  
10 25 100 100



给你一幅图有n个点,共有n-1条边,问你任意两条边的距离

思路:

递归深搜刚开始用栈超时

如果与st点连接的点没有搜过就先记录length,在递归调用dfs,

#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<vector>
#include<algorithm>
using namespace std;
const int inf = 4e4+10;
struct node{
int v;
int length;
}th[inf];
vector<struct node>s[inf];
bool vis[inf];
int ans;
int n,m;
int st,ed;
bool dfs(int st)
{
    vis[st]=true;
    for(int i = 0;i < s[st].size(); i++){
        if(vis[s[st][i].v]==false){
            ans+=s[st][i].length;
            if(s[st][i].v == ed){
                printf("%d\n",ans);
                return true;
            }
            if(dfs(s[st][i].v)==false){
                ans-=s[st][i].length;
            }
        }
    }
    return false;
}
int main()
{
    int num;
    scanf("%d",&num);
    int a = 10;
    while(num--){
        scanf("%d %d",&n,&m);
        for(int i = 0; i < n-1 ;i++){
            int u,v;
            scanf("%d %d %d",&u,&v,&th[i].length);
            th[i].v=v;
            s[u].push_back(th[i]);
            th[i].v=u;
            s[v].push_back(th[i]);
        }
        for(int i = 0;i < m; i++){
            scanf("%d %d",&st,&ed);
            memset(vis,false,sizeof(vis));
            ans=0;
            dfs(st);
        }
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值