1003. Emergency (25)(经典的dfs)

As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of rescue teams in each city and the length of each road between any pair of cities are marked on the map. When there is an emergency call to you from some other city, your job is to lead your men to the place as quickly as possible, and at the mean time, call up as many hands on the way as possible.

Input

Each input file contains one test case. For each test case, the first line contains 4 positive integers: N (<= 500) - the number of cities (and the cities are numbered from 0 to N-1), M - the number of roads, C1 and C2 - the cities that you are currently in and that you must save, respectively. The next line contains N integers, where the i-th integer is the number of rescue teams in the i-th city. Then M lines follow, each describes a road with three integers c1, c2 and L, which are the pair of cities connected by a road and the length of that road, respectively. It is guaranteed that there exists at least one path from C1 to C2.

Output

For each test case, print in one line two numbers: the number of different shortest paths between C1 and C2, and the maximum amount of rescue teams you can possibly gather.
All the numbers in a line must be separated by exactly one space, and there is no extra space allowed at the end of a line.

Sample Input
5 6 0 2
1 2 1 5 3
0 1 1
0 2 2
0 3 1
1 2 1
2 4 1
3 4 1
Sample Output
2 4

求途中所有的从st到ed的最小路径的条数,并且从这些路径中求出结点权值之和最大的值

题解:

深搜加回溯有个技巧就是dis和Minren的值最好在参数传递的时候就算好

#include<iostream>

#include<cstdio>
#include<vector>
#include<algorithm>
#include<cstdlib>
#include<cstring>

using namespace std;

const int inf = 5e2 + 10;
int city, road, st, ed;
struct node{
int v;
int length;
}th;
vector<node>s[inf];
int ren[inf];
bool vis[inf];
int Mren, Mway = 0;
int Mindis = 1e8;
int dis = 0;
int Nren;
void dfs(int st, int dis, int Nren)
{
     int i;
     if(st == ed){
          if(Mindis > dis){
                Mindis = dis;
                Mren = Nren;
                Mway = 1;
            }
            else if(Mindis == dis){
                //Nren里记录的是当前遍历过的节点的权值之和
                //当距离相同时,要一个权值更大的
                if(Mren < Nren)
                   Mren = Nren;
                Mway ++;
            }
            return ;
     }
     //剪枝,当目前的dis已经超过Mindis了就没有在搜下去的必要了
     //if(Mindis < dis)
       // return ;
    for( i = 0 ; i < s[st].size(); i ++){
        if(vis[s[st][i].v] == false){
            vis[s[st][i].v] = true;
            dfs(s[st][i].v, dis + s[st][i].length, Nren + ren[s[st][i].v]);
            //回溯,为了找出所有的到ed的路
            vis[s[st][i].v] = false;
        }
    }
}
int main()
{
    int i;
    scanf("%d %d %d %d", &city, &road, &st, &ed);
    memset(vis, false, sizeof(vis));
    for( i = 0; i < city; i ++)
        scanf("%d", &ren[i]);
    for( i = 0; i < road; i ++){
        int u, v;
        scanf("%d %d %d", &u, &v, &th.length);
        th.v = u;
        s[v].push_back(th);
        th.v = v;
        s[u].push_back(th);
    }
    vis[st] = true;
    Nren = ren[st];
    dfs(st,0,ren[st]);
    cout<<Mway<<" "<<Mren<<endl;
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值