F - Friends

Alice lives in the country where people like to make friends. The friendship is bidirectional and if any two person have no less than k friends in common, they will become friends in several days. Currently, there are totally n people in the country, and m friendship among them. Assume that any new friendship is made only when they have sufficient friends in common mentioned above, you are to tell how many new friendship are made after a sufficiently long time.

Input

There are multiple test cases.

The first lien of the input contains an integer T (about 100) indicating the number of test cases. Then T cases follow. For each case, the first line contains three integers n, m, k (1 ≤ n ≤ 100, 0 ≤ m ≤ n×(n-1)/2, 0 ≤ k ≤ n, there will be no duplicated friendship) followed by m lines showing the current friendship. The ithfriendship contains two integers ui, vi (0 ≤ ui, vi < nui ≠ vi) indicating there is friendship between person ui and vi.

Note: The edges in test data are generated randomly.

<h4< dd="">Output

For each case, print one line containing the answer.

<h4< dd="">Sample Input

3
4 4 2
0 1
0 2
1 3
2 3
5 5 2
0 1
1 2
2 3
3 4
4 0
5 6 2
0 1
1 2
2 3
3 4
4 0
2 0

<h4< dd="">Sample Output

2
0

4

很暴力的一道题目,我起先还以为后面结交成功不会对前面已判断的人产生影响,结果wr来一发,在想想感觉后面的会影响前面的结果所以就改了代码,让每个人的每次遍历都从0开始,感觉可以解决前面没考虑到的情况,然而结果有wr了,后来才知道一旦图结构有一次变动那么就要把整个图重新遍历一遍,直到图结构不变为止,这样关系就不会再变了



#include <bits/stdc++.h>

using namespace std;
int main()
{
    int num;
    scanf("%d", &num);
    while(num --){
        int n, m ,k;
        bool fou[1100];
        vector<int>v[1100];
        scanf("%d %d %d", &n, &m, &k);
        for(int i = 0; i < m; i ++){
            int fr, to;
            scanf("%d %d", &fr, &to);
            v[fr].push_back(to);
            v[to].push_back(fr);
        }
        int tot = 0;
        bool con = true;
        while(con){
            con = false;
            for(int i = 0; i < n; i ++){
                memset(fou, false,sizeof(fou));
                set<int>s;
                int len = v[i].size();
                for(int j = 0; j < len; j ++){
                    fou[v[i][j]] = true;
                    s.insert(v[i][j]);
                }
                int same;
                for(int j = i + 1; j < n; j ++){
                    same = 0;
                    if(!fou[j]){
                        int len2 = v[j].size();
                        for(int z = 0; z < len2; z ++){
                            if(s.find(v[j][z]) != s.end()){
                                same ++;
                            }
                        }
                        if(same >= k) {
                            tot ++;
                            con = true;
                            s.insert(j);
                            v[i].push_back(j);
                            v[j].push_back(i);
                        }
                    }
                }
            }
        }
        cout << tot << endl;
    }
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值