Frogger

ZOJ Problem Set - 1942
Frogger

Time Limit: 2 Seconds       Memory Limit: 65536 KB

Freddy Frog is sitting on a stone in the middle of a lake. Suddenly he notices Fiona Frog who is sitting on another stone. He plans to visit her, but since the water is dirty and full of tourists' sunscreen, he wants to avoid swimming and instead reach her by jumping. 

Unfortunately Fiona's stone is out of his jump range. Therefore Freddy considers to use other stones as intermediate stops and reach her by a sequence of several small jumps. 

To execute a given sequence of jumps, a frog's jump range obviously must be at least as long as the longest jump occuring in the sequence. 
The frog distance (humans also call it minimax distance) between two stones therefore is defined as the minimum necessary jump range over all possible paths between the two stones.

You are given the coordinates of Freddy's stone, Fiona's stone and all other stones in the lake. Your job is to compute the frog distance between Freddy's and Fiona's stone.


Input

The input will contain one or more test cases. The first line of each test case will contain the number of stones n (2 <= n <= 200). The next n lines each contain two integers xi, yi (0 <= xi, yi <= 1000) representing the coordinates of stone #i. Stone #1 is Freddy's stone, stone #2 is Fiona's stone, the other n-2 stones are unoccupied. There's a blank line following each test case. Input is terminated by a value of zero (0) for n.


Output

For each test case, print a line saying "Scenario #x" and a line saying "Frog Distance = y" where x is replaced by the test case number (they are numbered from 1) and y is replaced by the appropriate real number, printed to three decimals. Put a blank line after each test case, even after the last one.


Sample Input

2
0 0
3 4

3
17 4
19 4
18 5

0


Sample Output

Scenario #1
Frog Distance = 5.000

Scenario #2
Frog Distance = 1.414


Source:  University of Ulm Local Contest 1997
以往我们用的最短路dis数组里存的是总距离,但这题dis数组存的是每条路径中的其中最长的一段,但过程和迪杰斯特拉的过程一样
#include <bits/stdc++.h>

using namespace std;

const int inf = 0X3f3f3f3f;
struct node{
double x, y;
}th[220];
double dis[220], tu[220][220];
bool vis[220];
void dj(int n)
{
    for(int i = 0; i < n; i ++) dis[i] = tu[0][i];
    memset(vis, false, sizeof(vis));
    dis[0] = 0;
    vis[0] = true;
    for(int i = 0; i < n - 1; i ++){
        double Min = inf;
        int wei = 0;
        for(int j = 0; j < n; j ++){
            if(!vis[j] && dis[j] < Min){
                Min = dis[j];
                wei = j;
            }
        }
        vis[wei] = true;
        for(int j = 0; j < n; j ++){
            if(tu[wei][j] < dis[j] && !vis[j]){
                dis[j] = max(dis[wei], tu[wei][j]);
            }
        }
    }
}
int main()
{
    int n;
    int N = 0;
    while(~scanf("%d", &n) && n){
        for(int i = 0; i < n; i ++){
            scanf("%lf %lf", &th[i].x, &th[i].y);
        }
        for(int i = 0; i < n; i ++){
            for(int j = 0; j < n; j ++){
                tu[i][j] = tu[j][i] = sqrt((th[i].x-th[j].x)*(th[i].x-th[j].x) + (th[i].y-th[j].y)*(th[i].y-th[j].y));
            }
        }
        dj(n);
        printf("Scenario #%d\nFrog Distance = %.3f\n\n", ++N, dis[1]);
    }

    return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值